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1Welcome to PREMIER+™ 2 
Create

Use PREMIER+™ 2 Create to create beautiful embroideries on your 
computer.

To get started with PREMIER+™ 2 Create, open it and create embroideries using 
the ExpressDesign Assistant to automatically create designs from a picture, or 
design over a picture with QuickStitch and QuickTrace or Freehand features. 
Choose stitch line and fill types for your design.

ExpressDesign Assistant
PREMIER+™ 2 Create includes the ExpressDesign Assistant. Use it to 
automatically create embroideries from a picture, either to fit the current hoop or 
to fit an area you select. 

Quick Create and Shape Features
QuickStitch™ and QuickTrace are alternatives to the ExpressDesign Assistant for 
creating sections of your design.

With QuickStitch™, click in an area and stitches are produced automatically in an 
instant! Choose to embellish your designs with motifs, running, double or triple 
outline stitches, motif lines, borders with any combination of straight lines and 
curves or appliqué.

The QuickTrace feature automatically creates stitches that follow a continuous 
line. Create a Double trace , Quadruple trace , Satin line  or Motif line  
trace.

Also in Quick Create, create one of 75 shapes automatically as a fill area or line.
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Freehand and Precise Create Features
The Freehand and Precise Create features allow you to work with your stitches in 
detail. Draw an outline, place points, or draw Bezier curves around an area of the 
picture and the stitches appear with your choice of pattern. Include a satin stitch 
or other line border if you wish, and set the angle of stitching to any degree. Insert 
holes where you choose.

Choose Satin Column  (including over 250 patterns, and multigradient and 
multicolor gradient options for color blending), Satin Areas  or constant width 
Satin Lines  and emboss them with needle point highlights. Create Feathered 
Satin  and texture either or both edges for special embroidery effects on fur or 
flowers. Create columns of Tapered Motifs .

Make cutwork designs easily with Richelieu Bars . Use other features such as 
Double Zigzag  stitch, Crosshatch Fill  and Curved Crosshatch Fill  to 
create free-standing lace.

Add individual stitches in straight or curved lines of Running, Double and Triple 
Stitch from 1 to 12mm.

Design Choices
Adjust designs using easy editing features: Navigate around the design with the 
Filmstrip, change easily between lines, fills, stitch types and patterns and so much 
more.

Fill patterns and techniques are amazing – choose from over 250 fill patterns , 
or make your own. Emboss patterned fill or satin areas, or satin columns, with 
personal highlights. Use single gradient density to produce beautiful shading effects, 
and multicolor gradient density to produce gradual shimmering color changes.

Beautiful fill types include Radial , Spiral , Shape  with 75 shape options 
and motif options, QuiltStipple , Contour , Crosshatch , Echo  and 
MultiWave  Fill. Curved Crosshatch Fill  provides wonderful intersecting 
patterns for three-dimensional effects.

Choose from machine stitch Motifs or Universal Motifs such as the beautiful Hand 
Stitches for Motif Fill areas. Even create your own motifs!

Open PREMIER+™ 2 Create by clicking its icon in the Launchpad , or by 
double-clicking its icon  in the Finder. The PREMIER+™ 2 Create work area 
appears.

This user guide provides instructions to help you design embroidery projects in 
PREMIER+™ 2 Create. In addition to this book, other resources are available.

Reference Guide
The Reference Guide shows how to start the app and provides a quick tour of the 
main screen. The Reference Guide is supplied in PDF format , ready for printing 
and contains full reference information.
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Help
The integrated help contains full reference information. Click the Help button . 
Where available, a help topic appears that is relevant to the selected item. 
Alternatively, use the Help menu.

Viewing and Printing PDF Guides
To find all the Reference and Sample Guides for your PREMIER+™ 2 Embroidery 
System software, go to Home/Premier+2/Guides, then double-click Reference 
Guides or Sample Guides. Select the desired PDF guide.

Note: To view and print the PDF Guides, you may use Preview which is included in 
your Mac® OS.

Readme
The most up-to-date details about the PREMIER+™ 2 Embroidery System are in 
the Readme.rtf file available when you install your PREMIER+™ 2 Embroidery 
System.

Internet FAQs
The Internet FAQ option on the Help menu connects to a database of frequently 
asked questions about the PREMIER+™ 2 Embroidery System. Search topics 
relating to the app you are using, or search all topics.

Tutorials
Interactive training exercises are available for many of the apps. They provide a 
'show-me' experience that will help you learn how to use key features of the 
software. The tutorials are found in the online Learning Center on the Internet. 
Use the Help menu, or browse to EmbroideryLearningCenter.com.

Sample Files
Samples are included for your use.The sample files are installed to subfolders of 
Home/Premier+2/Samples/Create or the folder of your choice.

Further Information
For general information on installing the PREMIER+™ 2 Embroidery System, refer 
to the PREMIER+™ 2 Embroidery System Getting Started Guide.

About PREMIER+™ 2 Create
Access via the PREMIER+™ 2 Create menu. The version number of PREMIER+™ 
2 Create is given here. You will need this if you contact technical support at any 
time.

Starting PREMIER+™ 2 Create
■ Click the PREMIER+™ 2 Create icon  in the Launchpad.

■ Double-click the PREMIER+™ 2 Create icon  in the Finder.
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2Tools and Techniques

Get familiar with the tools you use to create embroidery designs 
with PREMIER+™ 2 Create.

Each embroidery design outline that you create with PREMIER+™ 2 Create is an 
individual document.

The first time you open PREMIER+™ 2 Create (by clicking its icon in the 
Launchpad or by double-clicking its icon in the Finder), the PREMIER+™ 2 Create 
work area appears. This is where you will create and edit your embroideries.

The work area is surrounded by the selected hoop.

The PREMIER+™ 2 Create Window

The Toolbar
The PREMIER+™ 2 Create toolbar gives one-click access to many of the features 
you will use as you work in PREMIER+™ 2 Create. You can add, remove, or 

Toolbar: customize it to show the tools you use frequently

Control PanelWork AreaFilmStrip

Menu bar
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rearrange toolbar buttons as desired. The default set of toolbar buttons is shown 
below.

The Create Toolbars
Use the Create toolbars (Quick Create, Freehand Create and Precise Create) to 
create embroidery designs on the work area, selecting fill and line types. The 
Quick Create toolbar is shown below.

See “Quick Create” on page 32, “Freehand Create” on page 34 and “Precise 
Create” on page 34.

Control Panel
Use the Control Panel to use the color worksheet and Filters to select parts of the 
design to be edited.

To Open the Control Panel
■ Click the Control Panel button  in the toolbar.

Menu Bar
The PREMIER+™ 2 Create menu bar is visible if PREMIER+™ 2 Create is the 
active window. Each open embroidery or design outline also has its own document 
window showing its name.

There are seven menus in addition to the Apple ( ) menu and the application 
menu: File, Edit, View, Create, Object, Window and Help.

■ To access the menu options, use the mouse to pull them down from the menu bar.

FilmStrip
In the FilmStrip you can view the numbered sequence of objects, select an object, 
change the sequence of objects, select objects to display, delete objects, insert 
Color Changes and Stops, view the properties of the selected object and change 

Assistants: Access the ExpressDesign assistant
Actions: Insert, Save, Print and other actions

Enlarge or reduce your view of the design Choose a Hoop

Load, fade or move background

Object, 3D or 2D View

Control Panel
FilmStrip

Preview Design

Group and Ungroup objects

Use a selection tool to select objects

Select Quick Create, Freehand Create or Precise Create

Change the color
Choose a fill for the area

Choose a border or line type

Add appliqué to an area Draw a MultiWave line on a MultiWave fill 

Select a Shape and create it as a line or fill area 

Trace a picture outline as a line of stitches

Emboss a fill or column
Create a hole in the fill

Create a satin area
Set the stitch options

Create a QuickStitch™ area or line
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the properties of objects globally or in a selected group. See “FilmStrip” on 
page 24.

Work Area
The work area is the area where embroidery design outline files are loaded. The 
work area includes the area surrounding the selected hoop. It is where you make 
changes to an embroidery. The stitch area is the available area inside the selected 
hoop.

Stitches are drawn in the appropriate colors. The embroidery 
design is shown in object view, 3D or 2D. The background color 
and texture can be changed using PREMIER+™ 2 Configure. You 
can also load a background image.

In Object view  an outline of the objects in the design is 
shown.

In 3D view  the embroidery design, background and hoop are shown, with blue 
corners showing the stitch area within the hoop.

In 2D view , stitches are shown as lines, together with the object outlines.

Background Grid
The work area has a grid. Zooming in or out makes the grid squares look bigger or 
smaller.

View the object color in
the Thread Color Bar

The first object is always a color

Objects are shown by their
shape or a marker

View the name of the object type

Scroll up and down the FilmStrip

Use the Layout Order buttons
to move objects in the FilmStrip

Select the last visible object

No line between linked objects

Line between chains 
of linked objects

Display objects within groups

Hoop Corner
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Select the Grid and its Size
■ To turn the Grid on or off, choose View > Grid (or ⌘.).
■ To change the size of the grid squares, choose PREMIER+™ 2 Create > 

Preferences (or ⌘,) and set the size.

Hoop
By default, the hoop is shown at a size so that the hoop fills the window, as if you 
had clicked Zoom To Fit .

To Select a Hoop
■ Click Hoop  in the toolbar, or choose Edit > Hoop to open the Hoop dialog. 

Color Select
The Color Select area of the Control Panel shows the colors used in the selected 
embroidery. See “Use the Color Worksheet” on page 21.

Zooming In or Out
You can enlarge (zoom in) or reduce (zoom out) your view of the work area.

Zoom To Fit shows the hoop so that it fills the window. This is the default size. 
Click the center marker on the zoom slider to see the embroidery at 100% or real 
size. See “Zooming In or Out” on page 16.

Keyboard Shortcuts and Shortcut Menus
You can use the keyboard to perform many of the 
PREMIER+™ 2 Create menu tasks and commands. To 
see a full list of keyboard shortcuts, open 
PREMIER+™ 2 Create and choose Help > Keyboard 
Shortcuts. 

Many commands are available from shortcut menus 
accessed from the design you are creating. 

To Open a Shortcut Menu
■ Press the Control key while you click on an object in the work area or FilmStrip.
■ Right-click on the mouse or trackpad.

To open the Assistants Menu
■ Click Assistants  on the toolbar. The Assistants pop-up menu opens.

To open the Actions Menu
■ Click Actions  on the toolbar. The Actions pop-up menu opens.
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Different options are available, depending on what is selected. For example, Finish 
the selected function, Properties or Global Properties, and so on.

PREMIER+™ 2 Create Terms and Conventions
For a general overview of terms and conventions, please refer to the PREMIER+™ 
2 Embroidery System Getting Started Guide.

On-screen pointers
The mouse pointer is most commonly shown as an arrow  on the screen. The 
following pointers are also used:

I-beam Used when entering text, e.g. in the Notes dialog.

Move A four-headed arrow is used when the pointer is over the 
selection box for one or more blocks or embroideries, or when 
Move Background  is selected. It is also used when moving 
the crop area in the Rotate and Crop Picture page of the 
assistants.

Zoom To Rectangle Used to drag an area to zoom in to.

Adjust/Resize A diagonal double-headed arrow is used when the pointer is 
over the square corner handle  for a selection box. It is also 
used when moving a crop line in the Rotate and Crop Picture 
page of the assistants.

Rotate Used when the pointer is over the Rotate handle on a selection 
box.

Horizontal A horizontal double-headed arrow is used when the pointer is 
over the flip horizontal handle  on a selection box.

Vertical A vertical double-headed arrow is used when the pointer is over 
the flip vertical handle  on a selection box.

Box Select The Box Select pointer appears when Box Select is chosen. It 
also appears when ExpressDesign into Rectangle is chosen in the 
assistants.

Freehand Select The Freehand Select pointer appears when Freehand Select is 
chosen.

Freehand Point 
Select

The Freehand Point Select pointer appears when Freehand Point 
Select is chosen.

Measure The Measure pointer appears when the Get Length function is 
selected.

Pick Color The Pick Colors pointer appears when picking colors from a 
picture for thread colors in the Choose Thread Colors page of 
the ExpressDesign Assistant, or in a background image.

Freehand Point The Freehand Point pointer appears when adding points to a line 
with the Precise Create or Freehand Point functions.
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Multi-Touch Gestures
Multi-Touch gestures are used when viewing and moving embroideries in 
PREMIER+™ 2 Create.

■ To set the use of Multi-Touch Gestures, scroll bars and secondary click options, 
choose Apple Menu > System Preferences, then select Mouse or Trackpad to set 
the preferences for your hardware.

Autoscroll
You can autoscroll on a portable Mac’s Multi-Touch trackpad, a Magic Trackpad or 
a Magic Mouse.

When you drag within a document, the autoscroll feature moves the pointer 
automatically, changing the view of the work area. This is useful when zoomed in. 
Use autoscroll while moving or resizing selected objects, or when creating objects 
using the Freehand Create (Freehand Tablet) functions.

■ On a portable Mac’s Multi-Touch trackpad, or a Magic Trackpad, use a two finger 
swipe.

■ On a Magic Mouse, use a one finger swipe.

Pinch to zoom
You can use Pinch to zoom on a trackpad to zoom in and out. 

■ On a portable Mac’s Multi-Touch trackpad, or a Magic Trackpad, pinch two fingers 
to zoom in, and spread two fingers to zoom out.

Note: You must set the trackpad scroll and zoom options to Zoom in or out. 

Bezier Mode The Bezier Mode pointer appears when you draw lines in Bezier 
Mode.

Convert Points to 
Symmetric

The Convert Points to Symmetric pointer appears when you 
change the selected point in a Bezier line to a Symmetric point.

Convert Points to 
Smooth

The Convert Points to Smooth pointer appears when you 
change the selected point in a Bezier line to a Smooth point.

Convert Points to 
Corner

The Convert Points to Corner pointer appears when you 
change the selected point in a Bezier line to a Corner point.

Adjust Nodes When nodes placed by the Freehand functions are adjusted, the 
pointer becomes a small cross.

Insert Point The Insert Point pointer appears when inserting points into an 
existing object line.

Remove Point The Remove Point pointer appears when removing points from 
an existing object line.

No Entry The No Entry pointer appears when the pointer is outside the 
editing area, for example if you try to pick colors outside a 
background image.
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Swipe between pages
When viewing the Pattern pages for Pattern fill, swipe with three fingers on a 
trackpad, or two fingers on a mouse, to move between the pages of patterns.

■ Choose Apple Menu > System Preferences, then select Mouse. In More Gestures, 
select Swipe between pages: Swipe left or right with two fingers.

■ Choose Apple Menu > System Preferences, then select Trackpad. In More 
Gestures, select Swipe between pages: Swipe with two or three fingers.

File Formats

Embroidery Design Files
PREMIER+™ 2 Create can only load embroidery design outlines in files with the 
extension .edo. PREMIER+™ 2 Create saves embroidery design outline files in .edo 
format. When a design is saved, the picture is saved with it.

Embroidery Files
PREMIER+™ 2 Create can insert any of the following embroidery file formats: 
Brother/Babylock/Bernina PEC (.pec), Brother/Babylock/Bernina PES (.pes version 
2 - 10), Compucon/Singer PSW (.xxx), Husqvarna Viking / Pfaff (.vp4, .vp3, .vip), 
Husqvarna (.hus, .shv, .dhv), Janome (.jef, .sew), Melco (.exp), Pfaff (.pcs), Tajima 
(.dst) and Toyota (.10*).

PREMIER+™ 2 Create exports embroidery files in any of the following embroidery 
file formats: Husqvarna Viking / Pfaff (.vp4, .vp3, .vip), Brother/Babylock/Bernina 
PEC (.pec), Brother/Babylock/Bernina PES (.pes version 2 - 10), Compucon/Singer 
PSW (.xxx), Husqvarna (.hus, .shv), Janome (.jef, .sew), Melco (.exp), Pfaff (.pcs), 
Tajima (.dst) and Toyota (.10*).

Note: The preferred file format for saving embroideries is .vp4, as this will preserve  
the separate part of multipart designs. It also preserves thread color information 
and notes.

Image Files
The following popular image file formats may be loaded: Bitmap (.bmp), 
Encapsulated PostScript (.epi, .eps), Graphics Interchange Format (.gif), JPEG-JFIF 
Compliant (.jpg, .jfif, .jpeg), JPEG 2000 (.jp2, jpf), JPEG Multi-Picture Object (.mpo), 
Photoshop (.psd), Portable Document Format (.pdf), Portable Network Graphics 
(.png), Postscript (.ps), Tagged Image File Format uncompressed (.tiff, .tif), Camera 
RAW (.raw & many others), High Dynamic Range (.exr, hdr).

These additional formats can also be loaded: Apple Icon (.icns), Fax (.fax & many 
others), Linux Icon (.xbm), Macintosh Picture (.pct, .lpic, .pict), MacPaint (.mac, 
.pnt, pntg), Microsoft Icon (.cur, .ico), Silicon Graphics (.rgb, .sgi) and Truevision 
TGA (.targa, tga).
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3The Design Creation Process

PREMIER+™ 2 Create is used to create designs for embroideries.

Use a design outline file made in PREMIER+™ 2 Create to create an embroidery at 
any time. Resize the same design to create otherwise identical embroideries for 
different hoops.

Start with a picture.

View and create objects in the design
 in the work area.

Use the ExpressDesign Assistant 
to create a design.

View and edit objects as 3D, 2D or outlines.

Add areas, for example tapered motifs or 
Richelieu bars.

Edit areas, for example to specialty fills.
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In PREMIER+™ 2 Create, you work with objects of different stitch types, not 
individual stitches.

Use New to open a new work area and start a new design.

Create a design automatically from a picture to fill the hoop, or part of it, with the 
ExpressDesign Assistant.

On the main screen, you can Open a design, or Open Recent.

Note: To open an embroidery as a design, use New to start a design with no 
picture. Choose Edit > Insert > Insert Embroidery to convert an embroidery to a 
design. 

When starting from a blank design, you may choose a hoop, and start creating your 
design with the Freehand, Command and Column features. However, it is more 
common to follow a picture when creating a design. 

Use Load Background  to open a picture, or choose PREMIER+™ 2 Create > 
Services > Import Image to load a picture from a scanner or digital camera. Start 
creating your design with QuickStitch™ and Freehand features in the work area.

Save finished designs with Save, then create the final embroidery with Export 
Embroidery. When the design is exported, trims and ties are added automatically 
according to the settings in Creating Stitches Preferences .

How to Create New Designs
There are three ways to make a new design:

• Create a design automatically with the ExpressDesign Assistant. The assistant 
requires a picture to convert to a design.

• Load a picture, then create a design on the work area of PREMIER+™ 2 Create 
by following the picture automatically with the QuickStitch™ and QuickTrace 
features. Additional design elements can be added using the Freehand Create 
(drawing outlines with a mouse or on a tablet) or Precise Create (placing points 
or drawing Bezier lines) features, as well as Shapes and Columns.

• Create a free-form design, with no background picture, mainly using the 
Freehand, Shape, Column, and Command features in the work area.
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The ExpressDesign Assistant
Use the ExpressDesign Assistant to create new designs automatically from 
pictures. There are three design types that can be created in the ExpressDesign 
Assistant: Quick Embroidery, Quick Trace and Quick Border.

There are two ways to start the ExpressDesign Assistant to create a new design.

■ Use ExpressDesign into Hoop to use the dimensions of your current hoop.
■ Use ExpressDesign into Rectangle to create a new design in the ExpressDesign 

Assistant that fits proportionally in a rectangle you draw on the work area.

Using Existing Designs
Any design (.edo file) can be used as the starting point for a new design. This 
includes a design you may have just created with the ExpressDesign Assistant, 
which you can modify and embellish as desired.

For example, a design might be changed dramatically by adding or removing a 
border, changing the fill type, or changing the pattern in a fill area. Also, for a design 
that you wish to use at a different size, you could change line types from satin to 
running, triple or motif stitch. Any line or area can be changed to appliqué.

Use existing designs, and designs created in the ExpressDesign Assistant, to create 
new designs and design collages.

What Makes a Design
A design in PREMIER+™ 2 Create is composed of areas, lines, columns and 
commands.

• Areas: The area features are used to create many different types of filled or 

stitch areas in which fills, for example Pattern fill , (and holes) can be placed.

• Lines: The line features are used to create Running stitch  (standard or 

cutwork needle lines), Double stitch , Double Zigzag stitch , Triple 

stitch , Satin  or Motif lines . Lines may be created alone or to border 
an area. Lines or areas may be set as appliqués.

From a picture... ... to a complete design and embroidery.
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Note: Lines are defined by points, which can be moved to change the shape of 
the line, or the area it encloses.

• Columns: The column features are used to create Satin Column , Feathered 

Satin , Richelieu bars  and Tapered motifs .

• Commands: Commands are instructions such as a change of thread Color , 

an Alignment Stitch , or a Stop .

Note: The term ’object’ is used to refer to any or all of these.

When an embroidery is created from a design, each line or area is converted to 
stitches, and the stitch order is controlled by the order of the objects in the design.

Note: You can see the order of objects in the FilmStrip.

There are several ways to add objects to a design:

• Use the ExpressDesign Assistant to create a whole design, with all the necessary 
lines, areas and commands. Edit or add to the design as desired.

• Add new objects to a design which can be based on a picture shown in the 
background, and change the properties of those objects. 

• Insert complete design elements, embroideries, font characters, or copy and 
paste selections.

Pictures
Most designs are based on pictures, either by using the ExpressDesign Assistant or 
by following the picture on the work area of PREMIER+™ 2 Create.

Pictures for the ExpressDesign Assistant
If you wish to modify a picture before using it in the ExpressDesign Assistant, you 
will need to use a picture editor such as Preview. Adjust your picture, save it with a 
new name, then use the new picture in the ExpressDesign Assistant. 

Note: It is recommended to keep your original picture in case you wish to adjust it 
again with different options.

Pictures for QuickStitch™ and Freehand
The best size for a background picture for PREMIER+™ 2 Create is approximately 
1500x1500 pixels (or greater).

The QuickStitch™ features use defined color areas to place areas and lines. The 
Color Tolerance function allows you to merge different color shades to change the 
size of this area.
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Pictures as Backgrounds
Use Embroidery to Enhance a Picture
Using PREMIER+™ 2 Create with pictures allows you to choose different stitches 
to highlight the desired features in a picture printed on fabric. For example, outline 
a shape in complementary or contrasting thread colors, use metallic threads to add 
sparkle, create three-dimensional effects with shading and add embellishments with 
motifs.

■ To see stitches against a picture, choose View > Background Visibility > Fade 
Background to change the picture display between On, Faded and Off.

■ Use Alignment Stitches  to align the embroidery on a picture that you have 
printed on fabric.

Printing Pictures on Fabric
It is recommended to test the printouts of pictures onto the final fabric, as the 
colors may not be reproduced onto fabric in the same way as on the screen.

The picture can be printed with the colors faded by 50%. This is an effective 
technique for making the embroidery stand out over the picture.
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4Viewing Designs

Select the way you view your designs. Zoom in and out, switch 
between Object, 3D and 2D View, and use a grid for alignment. Load 
a background image, then move and fade it as desired. Use the 
Design Player and Life View to view how your embroideries will 
stitch out, and in 3D with a real-world perspective.

View Mode
Select Outline, Standard 3D, or 2D View stitch display with View Mode. 

Use 3D View to see the embroidery design, background and hoop in 3D mode. 
The stitches of the embroidery design have three-dimensional shading. The outline 
of the last created or selected area is shown.

Use Object View to view object outlines with no stitches.

Use 2D View to see the individual stitches in your embroideries as lines with no 
shading, together with the object outlines. Stitches are drawn in plain colors only, 
and stitches using multicolor threads are drawn using only the first color in the 
thread definition.

Zooming In or Out
You can enlarge (zoom in) or reduce (zoom out) your view of the work area.

Zoom To Fit shows the hoop so that it fills the window. This is the default size. 
Click the center marker on the zoom slider, or press ⌘1 to see the embroidery at 
100% or real size.

You can select the position and size of an area to zoom in on with Zoom To 
Rectangle.

2D shows stitches as
lines with no shading 

Create your embroidery in 3D View

Object shows object outlines without stitches

Use the slider to zoom in and out

Zoom To Rectangle 

Zoom Out

Zoom To Fit

Zoom In

Zoom 100%
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Magnify an area with Zoom To Rectangle
1 Select Zoom To Rectangle.

The pointer changes to the Zoom To Rectangle pointer .
2 Drag a rectangle around the area you want to zoom in to.
3 Release the mouse to zoom in.

Zoom To Rectangle is automatically deselected after you have 
used it.

Pan
When zoomed in, move around the work area using pan.

Note: The scroll bars may only appear when you are scrolling. To always show the 
scroll bars, choose Apple Menu > System Preferences > General > Show scroll 
bars: Always.

■ Drag the scroll bars.
■ Swipe with one finger on the Magic Mouse, or two fingers on the trackpad to scroll 

in any direction.

Note: When zoomed in, use Autoscroll while moving or resizing objects, or to 
assist in drawing new objects using the Freehand Create (Freehand Tablet) 
functions.

Get Length
Use Get Length to measure the distance between any two points on the work 
area. For example, use it to obtain the width of a design, or the distance between 
two sections.

Note: The length is shown in millimeters or inches, according to the setting for 
Show Measurements in PREMIER+™ 2 Configure. The alternative units are shown 
in parentheses.

Measure a Design with Get Length
1 Open a design.
2 Choose View > Get Length, or press ⌘L. 

The pointer changes to the measure pointer .
3 Drag across the part of the design you want to measure. 

A line will show the length you are measuring, and a tooltip 
displays the distance.

4 If desired, make a note of the number.
5 Drag to measure any other distances, as required.
6 Control–click, and choose "Finish Get Length" to deselect 

the function.
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Show and Hide Objects
Use the color worksheet and the Filter Objects buttons in the Control Panel to 
show and hide blocks of colors and object types in the design. You can also use the 
Draw Range slider bars to change the view of the design.

Use any combination of color block display, object filters and draw range, in 
combination with the FilmStrip, to hide objects. Hiding objects leaves the visible 
objects available for modification, without affecting the hidden objects. 

Hiding objects can help when you need to choose a set of objects that are difficult 
to isolate directly with the Select functions. For example, if you want to change the 
pattern in a group of fill areas using Global Properties, or to select a group of 
objects to copy.

To learn how to Go to

Insert a thread color change See “Add Color Change, Pick Color and Quick 
Colors” on page 19.

Show or hide a color block or change a 
color

See “Use the Color Worksheet” on page 21.

Step through color blocks in order See "Draw Next Color Block" in “Filters” on 
page 23.

Show or hide stitch types See “Filters” on page 23.

Click to select a color block

Show or hide a color
block in the design

Show & hide lines, fills, groups

Filter single/alignment stitches,
colors, stops and appliqué

Step through color blocks
Draw all objects

Move, insert and delete 

Delete holes, and
emboss and MultiWave lines

Check and edit the
Notes and Settings

points for object outlines

Show and hide objects

Change the color of the 
selected block Show Design Property Colors

Design Information

Convert Bezier object points
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Add Color Change, Pick Color and Quick Colors
Use Add Color Change , Insert Color Change in the FilmStrip, Pick Color  or 
Quick Colors to select a new thread color for objects you are about to add to the 
design. The initial color is set to medium blue. A Color Change command is shown 
by a small blue circle with a C .

Note: To change an existing color, in the Control Panel click the desired color in 
the color worksheet, then click Change Color  to see the Color Selection 
dialog. Alternatively, Control–click the color in the FilmStrip and choose 
Properties. See “Use the Color Worksheet” on page 21.

Add a Color Change
Use Add Color Change  to open the Color Selection dialog to insert a color 
change in your design.

■ Click Add Color Change  in the Quick Create, Freehand Create or Precise 
Create toolbar. 

■ Choose Create > Color Change
■ Control–click in the FilmStrip and choose Insert Color Change.
■ Press ^C

Pick a Color
Use Pick Color  to select a color from the background picture as the new 
thread color. The Color Selection dialog opens displaying that color.

■ Click Pick Color  in the Add Color Change pop-up menu in the Quick Create, 
Freehand Create or Precise Create toolbar, and click a color in the background 
picture. The Color Selection dialog opens at that color.

■ Choose Create > Pick Color, and click a color in the background picture. The 
Color Selection dialog opens at that color.

Show or hide color changes and Stop 
commands

See "Hide Stops and Colors" in “Filters” on 
page 23.

Read and edit the Notes and Settings See “Notes and Settings” on page 73.

Show all stitches and other objects See "Display All Objects" in “Filters” on 
page 23

Use Draw Range See “Draw Range” on page 23.

Select part or all of a design See “Select Objects” on page 54.

Change and delete objects See “Delete Object” on page 55.

Move and edit points See “Points” on page 59.

Convert points in Bezier objects See “Convert Points and Bezier Lines” on 
page 61.

To learn how to Go to
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The first Color Change is initially set to medium blue. 

Quick Colors
Use the Quick Colors palette to choose a color for the new thread color. A block 
of the color in the current thread range that is nearest to the chosen color is 
placed below the selected object in the FilmStrip.

■ Click Quick Colors in the Add Color Change pop-up menu in the Quick Create, 
Freehand Create or Precise Create toolbar, and click a color in the palette. The 
thread color block is placed below the selected object in the FilmStrip.

Effects
Use the Effects area to show the results of using thread effects or special needles.

Note: Only one thread effect can be used on any thread. In the Modify tab of 
PREMIER+™ 2 Embroidery Extra, most thread effects are not shown in the active 
subdesign, as it would be difficult to edit the stitches. They are shown in Design 
Player  and Life View , in addition to the other tabs.

To use Thread Effects
■ Click the desired color block in the list, then choose an effect:

• If you choose Puffy Foam , set the foam height. 

• If you choose Twin Needle , set the Twin Needle size. Click the color icon 

for the Second Color if you wish to use a different thread color. 

• For Dual Thread , it is recommended to change the Second Color. 

• For Felting Needle  select a color for the roving fiber for felting. 

• For Cutwork Needle , choose the angle for your needles.

Puffy Foam
Use Puffy Foam  to show the three-dimensional effect of stitching over 
embroidery foam.

Choose a thread range
View the thread ranges

Search by thread number

Click a thread color
to select a thread

View the thread 

Use the Colors window

Puffy Foam depth
Twin needle
stitch size & color

Two thread colors
Wing needle
Felting needle
Cutwork needle
angle

information

to match a color
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Dual Thread
Use Dual Thread  to show the effects of stitching out 
two threads through the same needle. This is particularly 
suited to blending threads for special effects, such as mixing a 
rayon thread with a metallic thread, as in the center of the 
star.

Twin Needle
Use Twin Needle  to show the effect of stitching out 

the color block with a twin needle. This creates a horizontal 
offset between the original thread color in the left-hand 
needle, and a second thread color in the right-hand needle.

There are several ways that the Twin Needle effect can be 
used, including:

• Use with running stitch to create a ribbon effect, typically 
using the same thread color in both needles

• Use with a low density fill area to blend two different 
thread colors and also have a lightly shadowed effect

Note: On the screen, the Twin Needle effect is shown 
horizontally from left to right. If you rotate an embroidery 
for stitching out, the twin needle stitchout will be different 
from the effect on screen.

Size

Twin Needle Size is only available if the Twin Needle effect 
is selected for the current color block. Choose the size of the gap between the 
twin needles.

Preview the effect of changing the twin needle size to help decide which needles to 
buy. Ensure that the desired size is recommended for embroidery on your 
machine.

Second Color

The second thread color for the twin needle is initially set to the same color as the 
original color block. Use Second Color  to choose a different thread for the 
second needle in the Color Selection dialog. The other color is displayed in the 
Twin Needle area.

Use the Color Worksheet
1 Open a design.
2 Click Control Panel, then click one of the color blocks in the color worksheet. The color 

selection dialog opens.
3 Change a color, and then close the color selection box. The color in the design changes.
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4 Deselect the checkbox next to one of the color blocks. The color can no longer be seen in 
the design.

5 Click Display All Objects  to show all of the colors again.

Secondary Colors
Extra design property colors for some objects are set in the properties dialog for 
that object, for example multigradient fills and the border for a fill area. They then 
appear as secondary colors in the color worksheet, and can be adjusted from 
there.

A multicolor gradient fill or satin column will show a hatched pattern in the 
FilmStrip. To view these colors in the worksheet, ensure that Design Property 
Colors  below the color worksheet in the Control Panel is selected.

Design Property Colors
Use Design Property Colors  to show or hide thread colors in the Color Select 
area that are part of an object’s property, for example an alternative border color 
or color gradients.

Pattern Fill with a 
border

The FilmStrip and 
worksheet show both 

colors

Set a separate border color 
in the Line tab of the 

Properties dialog

Multigradient Pattern Fill 
with a border

The FilmStrip and 
worksheet show all 

colors

Set the colors for the 
multigradient fill in the 

Properties dialog



PREMIER+™ 2 Create   Viewing Designs              23

Filters
The Filters buttons are used to hide and show the 
objects in the design by object type, and/or by 
color block sequence. When a filter is used to hide 
objects, the objects are hidden in the work area 
and in the FilmStrip.

The Hide Line Types filter  is used to hide and show Running, Double and Triple 
Stitches, Motif Lines and Tapered Motifs.

The Hide Fill Types filter  is used to hide and show Pattern Fill Areas, Motif Fill 
Areas and QuiltStipple, Shape, MultiWave, Radial, Spiral, Contour, Echo and 
Crosshatch Fill Areas.

The Hide Satin Area filter  is used to hide and show Satin Areas.

The Hide Column Types filter  is used to hide and show Satin Column, Richelieu 
Bars, Feather Satin and Satin Lines.

The Hide Single Stitches filter  is used to hide and show Single Stitches and 
Alignment Stitches.

The Hide Stops and Colors filter  is used to hide and show Color Change and 
Stop commands.

The Hide Groups filter  is used to hide and show Groups.

The Hide Appliqués filter  is used to hide and show Appliqué areas.

The Draw Previous Color Block filter  is used to step through the color blocks 
in reverse order.

The Draw Next Color Block filter  is used to step through the color blocks one 
at a time.

The Display All Objects  filter is used to display all objects and commands in the 
design.

Draw Range
Use the Draw Range to determine the range of visible objects.

The Draw Range has Start and End sliders, which are 
used to control which objects are displayed. Each step 
is one distinct object, similar to stepping through 
objects with the arrow keys. The upper slider bar sets the first object at the Start 
of the visible objects. The lower slider bar sets the End object. 

Note: When you set a Draw Range, only objects within the visible color blocks are 
displayed.
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FilmStrip
In the FilmStrip you can view the numbered sequence of objects, select an object, 
change the sequence of objects, select objects to display, delete objects, insert 
Color Changes and Stops, view the properties of the selected object and change 
the properties of objects globally or in a selected group.

To Open the FilmStrip
■ Click the FilmStrip button  on the toolbar.
■ Choose View > Show FilmStrip

FilmStrip Items
Starting at the top, the FilmStrip shows the numbered sequence of objects in the 
design. When all objects are visible, the first object at the top of the list is a Color, 
then any other objects that make up the design. The last object in the design is at 
the bottom of the list, together with the Layout Order functions. 

The currently selected object is highlighted in the FilmStrip, and objects can be 
selected directly in the FilmStrip.

Note: When objects are hidden, using the color worksheet, object filters, slider 
bars or FilmStrip options, they are also hidden in the FilmStrip.

Each item in the FilmStrip shows four pieces of information: the number, color, 
object and object type.

View the object color in
the Thread Color Bar

The first object is always a color

Objects are shown by their
shape or a marker

View the name of the object type

Scroll up and down the FilmStrip

Use the Layout Order buttons
to move objects in the FilmStrip

Select the last visible object

No line between linked objects

Line between chains 
of linked objects

Display objects within groups
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Note: Trims and ties are added automatically at export according to the settings in 
Creating Stitches Preferences ; they are not visible in the FilmStrip.

Select Objects in the FilmStrip
Until you select a specific object, the last visible object is selected automatically in 
the work area. 

1 Open a design.
2 Click the FilmStrip button  on the toolbar to open the FilmStrip. Alternatively, choose 

View > Show FilmStrip.
3 Click an object in the FilmStrip to select it. It is highlighted in blue.

If necessary, scroll to the object in the FilmStrip.
4 Click a different object in the work area. That object is now highlighted.

Note: To see an object in the work area when zoomed in, either Zoom To Fit  or use the 
scroll bars on the edges of the work area.

5 Click on the FilmStrip to highlight an object.
6 Press the up and down arrow keys to step up and down the list one object at a time, 

selecting each object.
7 Press the Page Up (or fn ↑) and Page Down (or fn ↓) keys to jump up and down the list 

one screenful at a time. Then click on the desired object to select it.
8 Press Home (or fn ←) to go to the first visible object.Then click on the desired object to 

select it.
9 Press End (or fn →) to go to the last visible object.Then click on the desired object to 

select it.
Alternatively, click Select Last Visible object  in the FilmStrip to jump to and select the 
last visible object.
Note: You can only select visible objects. If a filter (or other function) is used so that the 
selected object is no longer visible, the last visible object is selected automatically.

10 Click Display Group Contents  to show the objects within Groups. 
Note: When Display Group Contents is not highlighted only the Groups themselves can be 
seen.

11 Click an object in the FilmStrip and hold the Shift key. Then click an object several places 
below it. All of the objects in that sequence are highlighted and selected in the work area.

12 Click an object in the FilmStrip and hold the Command key. Then click a selection of other 
objects. These objects are highlighted and selected in the work area.
You can add objects to a sequence in this way.

Change the Sequence of Objects
Objects and groups of objects can be dragged to move them up and down the 
FilmStrip. This changes the order of the objects, and also changes the order in 
which the stitches are created for the final embroidery. Alternatively, use the 
Layout Order buttons.

To learn how to Go to

Change the sequence of objects in the 
FilmStrip

See “Change Objects’ Sequence” on page 56.
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FilmStrip Context Menu Options
Use the FilmStrip context menu to view options relating to the currently selected 
object or group of objects.

■ Control–click on an individual item in the FilmStrip to view its context menu, and 
choose an option from the menu.

Move an object within the FilmStrip See “Drag an Object within the FilmStrip” on 
page 57.

Move a group of objects in the FilmStrip See “Drag Several Objects in the FilmStrip” on 
page 57.

Use the Layout Order buttons to move 
objects in the FilmStrip

See “Move an Object With the Layout Order 
Buttons” on page 57.

To learn how to Go to

Display Only 
Selected

Show only the currently selected object or group. Use this to isolate a 
single object or group. For example, once an object is isolated, you can 

select it with Select All Visible  and move, resize, flip or rotate it.

Display Only 
From Start

Hide all objects after the selected object or group. Only the currently 
visible objects from the start to the selected object are shown.

Display Only To 
End

Hide all objects before the selected object or group. Only the currently 
visible objects from the selected object to the end of the design are 
shown.

Display All 
Objects

Display all objects and commands in the design.

Cut Delete the selected object or group from the screen and place it on the 
Clipboard.

Copy Make a copy of the selected object or group and place it on the clipboard 
for use in this app.

Paste Paste the object or group that has been cut or copied to the Clipboard 
onto the screen.

Duplicate 
Selected

Make a copy of the whole design or the currently selected objects, which 
is automatically pasted on the work area.

Delete Object Delete the selected object or group from the design.

Insert Color 
Change

Insert a Color Change after the currently selected object. The Color 
Selection dialog appears so you can choose the new color.

Insert Stop Insert a Stop after the currently selected object.
Note: A Stop is not inserted if this would place two Stops together.

Group Group selected objects together so they may be moved, resized or scaled 
and rotated together.

Ungroup Ungroup a selected group so that each object may edited independently.
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Backgrounds
Use the Background tools to load a background picture, to move a background, or 
to fade a background. See “Image Files” on page 10.

Note: The Background tools are only available after a Background has been 
selected.

Load Background
Use Load Background  to load a background picture.

■ Click the Load Background  button on the toolbar.
■ Choose View > Load Background.
■ Press ⇧⌘K

Use Load Background to load a picture. PREMIER+™ 2 Create displays the Load 
Background Image dialog so you can choose a picture to open.

Select Similar 
from Visible

Select all visible objects with similar properties.

Select Similar 
from Group

Select all objects with similar properties that are in the same Group.

Properties Show the properties dialog for the selected object or group. This is the 
same as using Control–click on the work area.

Global 
Properties

Show the properties dialog for the selected object. When the settings in 
the dialog are confirmed with the OK button, all visible objects of the 
same type will also have their properties changed to match the settings.

Scroll into View Automatically scroll the work area so that the selected object can be seen 
in the work area. 
Note: This option is only active when zoomed in. 

Layout Order Move objects in the FilmStrip.

Use Background On to show the 
picture in the background.

Use Fade 50% to show the 
picture in the background with 

the colors faded by 50%.

Use Background Off to hide the 
picture. 

Load a background
Fade the background

Move the background
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Note: You are warned if you try to load a picture when there is an existing 
background picture.

Background Visibility
Use Background Visibility  to open a pop-up menu and select one of the 
background visibility options.

• Background On shows the background at full visibility. 
• Background Off hides the background. 
• Fade Background opens the Fade Background dialog where you can set the 

visibility for the background picture. 

■ Click the Background Visibility  button on the toolbar, then choose Background 
On, Fade Background or Background Off from the pop-up menu.

Move Background
Use Move Background  to move and resize the background picture that you are 
using to create your embroidery design. The mouse pointer changes to a four-
headed arrow .

Using Move Background
1 Click the Move Background button . The mouse pointer changes to a four-headed 

arrow . 
Alternatively, choose View > Move Background (or press ⌥⌘K).

2 Drag the background around the hoop or project area. 
3 When the background is in the desired location, Control–click to deselect the function.

Resize a Background
1 Click the Move Background button . The mouse pointer changes to a four-headed 

arrow . 
Alternatively, choose View > Move Background (or press ⌥⌘K).

2 Drag the square resize handles using the two-headed resize pointer  to resize the 
background picture.

Choose a folder

Click to select a picture

Click Open to load

Search by name
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To keep the picture in proportion, hold down the Shift key. Hold down the Option key to 
resize from the center.

3 Release the mouse button, and then release the Shift key if you used that to keep the 
proportions. The background picture is redrawn at its new size.

4 When the background is the desired size, Control–click to deselect the function.

Fade Background
Use the Fade Background dialog to set the visibility for the background picture.

Delete Background
Use Delete Background to remove the background picture that you are using to 
create your embroidery design.

■ Choose View > Delete Background.
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Life View
Use Life View  to show how an embroidery exported from the project will look 
in 3D with real-world perspective. Zoom in to see detail, and move and rotate the 
embroidery in a three-dimensional view.

Note: Life View will not open if part of the embroidery is outside the hoop.

Use Life View  at any time when you want to see the design with no grid, 
stitches selected, or markers displayed, and when you want to see the effects of 
glow in the dark and solar reactive threads.

Design Information

Move around the window
Change the 3D viewing angle

Zoom in and out

Light and dark effects

Reset
Animation

Share a picture or video online
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Design Player
Use Design Player to play through the stitches in the embroidery design as if it was 
being stitched from an exported embroidery. All parts of the design that are within 
the hoop area are shown, whether or not they are selected. Designs are shown in 
3D .

Note: The current Optimize for Sewing settings from PREMIER+™ 2 Configure are 
used.

Note: The Design Player will not open if part of the embroidery is outside the 
hoop.

Use Share to save or share a picture or video of your design on your favorite social 
media site. Share over Facebook® , Flickr® , Twitter®  and YouTube® .

Using the Design Player
1 Choose File > Open (or press ⌘O).
2 Browse to Home/Premier+2/Samples/Create/Edo.
3 Scroll down to "Sleigh.edo".
4 Click to load the design into the work area.
5 Click Design Player . Alternatively, choose View > Design Player or press ⌘Y. 

The Design Player dialog opens and the embroidery is shown being stitched out.
6 Use the Play button  at the bottom left to start playing through the stitches in the 

embroidery.
7 Use the controls to play forwards for backwards through the embroidery at different 

speeds, jump to the start or end of the stitches, and stop at any time.

Start or pause play

Control play with
the slider

Design Information

Jump to first stitch

Jump to last stitch

Rewind

Play at double the
current speed
Share a picture 
or video online
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5Creating Design Elements

Use the Quick, Freehand and Precise Create tools to add objects to 
your design.

A design in PREMIER+™ 2 Create is composed of areas, lines, columns and 
commands (objects).

After creating any fill or satin area, or satin column, you can emboss it by placing 
needle points to enhance the pattern.

Note: Any line type can be converted to another 
line type, and most area types can be directly 
changed to any other area type. 

Create columns by placing alternate points.

Commands are instructions such as a change of 
thread color or a stop.

Creating Areas and Lines
Areas and lines are created using the 
QuickStitch™, QuickTrace and Freehand 
features, or automatically with the 
ExpressDesign Assistant.

Draw a line with the Freehand features, or follow a line in a picture with 
QuickStitch™, QuickTrace and the ExpressDesign Assistant.

Note: You can change an open line to a fill area. The fill area is created by closing 
the gap between the line ends, or by using the Closed Border option on the Line 
tab of the Fill Area and Line properties dialog. The points defining the area are not 
changed. This allows you to create a fill area with a closed or open border.

Quick Create
Use the features of the Quick Create tab (QuickStitch™, QuickTrace and Shape) 
to ceate design areas automatically.

Creating with QuickStitch™, QuickTrace and Shape
Change the color

Choose a fill for the area
Choose a border or line type

Add appliqué to an area Draw a MultiWave line on a MultiWave fill 

Select a Shape and create it as a line or fill area 

Trace a picture outline as a line of stitches

Emboss a fill or column
Create a hole in the fill

Create a satin area
Set the stitch options

Create a QuickStitch™ area or line



PREMIER+™ 2 Create   Creating Design Elements              33

Click in a defined color area, or on a defined color line, in the background picture 
to create a QuickStitch™ or QuickTrace line or fill. The area outline is filled or the 
line is followed automatically. 

Use Color Tolerance to choose the color shades used when defining the area, and 
to set the relative number of points in the outline for QuickStitch™ areas. Low 
produces a smoother outline, while High follows the lines of the picture more 
precisely.

Using Color Tolerance with QuickStitch™ and QuickTrace
1 Select the desired QuickStitch™ or QuickTrace function, according to the type of stitches 

you want over the picture area you are about to select. 
2 Click in the desired area (for example, on the cat’s left 

side) of the picture for QuickStitch™ functions or on 
the desired line for QuickTrace functions.

3 If Color Tolerance is enabled, the Color Tolerance dialog 
appears. 
A blue and white checkered pattern shows the area of 
the picture that will be filled or traced. If you have 
chosen to detect holes, any holes in the area will not 
contain the checkered pattern.

4 Use the slider to adjust the Color Tolerance value until 
the required part of the picture is selected.

5 For QuickStitch™ areas, select the relative number of 
points along the outline. Choose from Low, Medium and 
High. Low produces a smoother outline, while High 
follows the lines of the picture more precisely.

6 Click OK to confirm the desired area is highlighted, and the line or area is created.

Turning Color Tolerance Off
When Color Tolerance is not enabled, the stitch object(s) are created immediately, 
using only the color area that was selected. You can use the Color Tolerance 
option in General Preferences to turn Color Tolerance off, but this is only 
advisable if your picture has well defined flat color areas, and you have no need to 
select more than one color area to create new objects.

Shape
Use Shape  to select a shape and create a fill area, or line, in that shape. Then 
adjust its size and properties.

Note: Draw a ring, a square, a frame or other shape. Select a fill and line to draw a 
fill area surrounded by a border, or select a line type only to draw a closed line 
with no fill.

Creating with Freehand Create and Precise Create
The Freehand and Precise functions are used to create new stitch objects by 
creating object outlines directly on the design. The outlines may follow a 
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background picture, if desired, but the Freehand and Precise functions do not 
require a picture. Most of the Freehand Create functions are used by drawing an 
outline, and most of the Precise Create functions are used by placing points or 
drawing Bezier lines to define an outline.

Freehand Create
Use the Freehand Create functions  to create lines and areas by drawing 
outlines on the design with a pen on a graphics tablet, or by dragging with the 
mouse.

Note: All of the Freehand Create tools work in the same way, except for 
Commands and Columns.

Draw a Fill Area with Freehand Create
1 Select the stitch types.
2 Select Create Freehand Area or Line .
3 Draw one continuous line to create a line or area. 
4 Lift the pen or release the mouse button to complete the line or area. 
5 Draw another line to create another new object. 
6 Control–click to deselect the Freehand function when you have finished, or simply select 

another Create tool.
Note: Freehand Create provides a natural drawing experience and is generally 
recommended. When zoomed in, use Autoscroll to assist in drawing new objects.

Precise Create
Use the Precise, or Freehand Point functions, to create lines and areas  by 
placing a series of points that define the outline. 

Place Points with Precise Create
1 Select the stitch types.
2 Select Precise Area or Line . The Precise (Freehand Point) pointer  appears.

Change the color

Choose a fill for the area
Choose a border or line type

Add appliqué to an area Draw a MultiWave line on a MultiWave fill 

Place alternate points for a column

Emboss a fill or column
Create a hole in the fill

Create a satin area

Set the stitch options
Draw an area or line

Create a single or alignment stitch
Place a Stop command

Change the color

Choose a fill for the area
Choose a border or line type

Add appliqué to an area Place a MultiWave line on a MultiWave fill 

Place alternate points for a column

Emboss a fill or column
Create a hole in the fill

Create a satin area
Set the stitch options

Place points for an area or line

Create a single or alignment stitch
Place a Stop command

Draw a Bezier line
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Note: To create an area with Bezier lines, use Bezier Mode . See “Bezier Mode” on 
page 182.

3 Place each point with a single click.
Note: Hold down the Shift key to place square points for the precise positioning of corners 
and straight line sections.

4 To move a point, hover the pointer over the point and when the move pointer  appears, 
drag the point to the desired position.

5 Double-click or press Return to complete the outline.
6 Control–click to deselect the Precise function when you have finished, or simply select 

another Create tool.

Bezier Mode
Use Bezier Mode to draw shapes with finely graduated curves. Control the exact 
shape of the line using the black handles to either side of the points you place.

Click to place Corner points, or drag to place curve points with 
handles.

Note: For information on Control Points and the other Bezier Line 
editing tools, see “Convert Points and Bezier Lines” on page 61.

Area Types
Any area can have a border, or no border. The border can be closed or open, and 
it can use any line type. Holes can be defined inside any fill area. Appliqué 
properties may be set for any area or line. Use Break Apart on the Object menu to 
change an area with a border into separate fill area and line objects.

Note: Any fill area can be converted into a Satin Area, however any holes in the fill 
area will be lost.

Pattern Fill

Pattern Fill areas  contain small stitches with repeating patterns from an origin 
point that can be moved. Select from one of the themed collections. A pattern fill 
area can have holes defined inside it. The stitches can be at any angle and the 
density can be constant, gradient or multicolor as desired. Constant density fill 

Fill Area with Satin border and 
holes using Pattern Fill 109 from 

Hearts

Pattern Fill Area with 
Multicolor Gradient

Motif Fill Area with two motifs, 
13 and 19, from Hand Stitches 2
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areas can also have automatic underlay, which is turned off automatically for 
gradient density areas.

Note: If you change a gradient density fill back to standard, then you should also 
select the desired underlay.

Motif Fill
Motif Fill areas  contain repeated small stitches placed using one of the Universal 
or machine motif patterns. A motif fill area can also have holes defined inside it. 
The motifs can be at any angle and at different sizes, and different motifs can be 
used on alternating lines.

Shape Fill
Shape Fill areas  use one of 75 different shapes from an origin point that can be 
moved. Vary the stitch density, use running stitch or motif lines for the fill and add 
holes.

Radial Fill
Radial Fill areas  use a pattern of radiating lines from an origin point that can be 
moved. Vary the stitch density and add holes.

Spiral Fill
Spiral Fill areas  use a spiral pattern from an origin point that can be moved. Use 
constant or gradient density, and add holes.

Shape Fill Area using Shape 23 
and Motif 1 from Hand Stitches 1

Radial Fill with origin moved to 
top of heart

Spiral Fill using Gradient Density
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QuiltStipple Fill
QuiltStipple Fill areas  use stipple stitch in curved or straight lines. Vary the gap 
between stitch lines, use running or triple stitch, and add holes.

Contour Fill
Contour Fill areas  use contour stitch lines. Vary the gap between stitch lines 
and the length of the stitches, use running, double or triple stitch, and add holes.

Crosshatch Fill
Crosshatch Fill areas  use diamond, square and parallel crosshatch patterns, or 
select the angles for the crosshatch. Set the gap, style, line angle, stitch type and 
stitch length for the crosshatching, and add holes to the fill.

Note: Crosshatch fill is often selected for lace designs, typically using a Double 
Zigzag stitch type.

Curved Crosshatch Fill
Curved Crosshatch Fill areas  use curving lines in the crosshatch, which can be 
used to create a feeling of depth. They are used in quilting, and to create free-
standing lace.

QuiltStipple Fill using a curved 
style

Contour Fill, using Triple Stitch 
and a 3.0mm gap

Crosshatch Fill, using Diamond 
style and an Angle of 75 degrees

Curved Crosshatch Fill, using 
Square style and a Gap of 5mm

MultiWave Fill, using a density of 
15, a MultiWave Line, and a Hand 

Stitches 1, Pattern 1 motif

Echo Fill using Internal and 
External Lines, and rounded 

corners
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MultiWave Fill
MultiWave Fill areas  use a wave pattern defined by a line, or lines, drawn on the 
fill area. Vary the density, or use a motif for the stitch lines.

Echo Fill
Echo Fill  places echo lines within and/or around a shape. Choose from 
rounded, square and diagonal corners, set the gap between the echo lines and the 
number of lines, and select the stitch type and length.

Satin Areas
Satin Areas  contain zigzag stitches that fill the area 
from one end to the other at the same density. The stitch 
angle changes with the shape of the area, and can be 
adjusted as desired. Choose automatic edge walk and/or 
zigzag underlay.

Note: Satin Areas can be converted into any type of fill 
area. They cannot be created with a border, but a border 
can be placed around them using the Area Properties 
dialog.

Columns
Create Columns by placing points, or when using the Precise Create toolbar by 
drawing Bezier lines. The Column functions are found both on the Freehand and 
Precise Create toolbars. Place alternate points to define a column of any length. 
Choose a column type before creation, or change it afterwards in Column 
Properties.

Satin Column
Use Satin Column  to create a straight or curved column of parallel stitches. 
The column may be of any length.

Note: The recommended maximum length for satin stitches is around 8-10mm, 
otherwise the stitches may be loose and not lie flat. To create satin wider than this, 
either overlap satin columns, or use a satin area.

Continuous Satin Feathered Satin Richelieu Bars Tapered Motifs
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Feathered Satin
For lifelike realistic feathers or fur, use Feathered Satin , where the start and end 
points of the stitches are random rather than all parallel. Feathered satin may also 
be created with only one side feathered – the side where the first (A) or second 
(B) point was placed.

Richelieu Bars
Use Richelieu Bars  to create a column of short sections of satin perpendicular 
to the direction of the column. Choose the number of bars, and the width of the 
satin.

Note: Richelieu bars are typically used for cutwork designs.

Tapered Motifs
Use Tapered Motifs  to create a line of motifs that vary in size according to the 
width of the column.

Note: Tapered motifs are often used in lace designs.

Line Types
Choose a line type before drawing the line, or change it afterwards in Area 
Properties.

Running, Double and Triple Stitches
Set Running Stitch  from 0.3-12mm in 0.1mm steps (standard, or cutwork 
needle line with secure points). Set Double , Double Zigzag  and Triple  
stitch to any length from 1mm to 12mm.

Note: Double Zigzag is a special stitch type, recommended for lace. A running 
stitch line is retraced in a zigzag pattern to create a mesh.

Feathered Both Sides Feathered Side A Feathered Side B

Running Double Triple
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Motif Line
Motif lines  are lines of the chosen Universal or machine 
motif patterns.

Satin Line
Create Satin lines  where a line or border of satin stitches of constant width is 
desired. The line will be created along the center of the chosen line.

Note: Individual satin lines and the satin borders used around fills or appliqué are 
identical.

Commands
Commands are instructions such as the Add Color Change  that changes the 
thread at the start of a new color block, and the Stop  that tells an embroidery 
machine to stop without a color change.

Color changes, stops and alignment stitches are indicated by special blue and red 
markers on the work area.

Alignment Stitches
Use Alignment stitches  to add stitches at the beginning of an embroidery that 
you can use to align the embroidery, for example with a previously embroidered 
design. Alignment stitches are typically placed at the beginning of an embroidery. 
They are inserted after the currently selected object, but may be moved if desired. 
Alignment stitches are created as a cross, but may be altered after placement.

■ Select Alignment stitches , then click to place a point for the stitch. 

Color Change Stop Alignment Stitch
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Single Stitch
Use Single stitch  to create single stitches 
that are embroidered at whatever length they 
are made. Alternatively, if you select to Break 
Up into Smaller Stitches they will be broken up 
into stitches of Running Stitch at any length from 
1 to 12mm.

■ Select Single stitch , then click to place points for the stitches. 

Creating Motifs and Machine Stitches
Use Create Motif from Selection in the Edit menu to make a motif from a Running 
Stitch design that will be suitable as a repeated element. You can also use Export as 
Machine Stitch to use a design to create a .spx machine stitch for certain sewing 
machines. Save the design in .edo format in case you wish to edit it later.

See “Motifs and Machine Stitches” on page 51.

Objects Created in the ExpressDesign Assistant
Lines and areas created in the ExpressDesign Assistant may be modified in the 
same way as those created by any other method. When the ExpressDesign 
Assistant is used to create a new design, the design will fit the hoop or use the 
selected design size.

Note: Columns are not created by the ExpressDesign Assistant. Any satin will be a 
Satin Area or a Satin Line.
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Area Properties
Use the Area properties dialog to set properties before creation, or to change the 
fill and line type for a previously created area or line. Then edit the properties 
using the tabs in the dialog.

Note: The options available below the two pop-up menus will vary, depending upon 
the selected fill and line type.

Note: You can change a previously created area to any other fill or line type in the 
pop-up menus, including No Fill or No Border Line.

To show the Area properties dialog
■ Choose an object type from the Options pop-up menu on the Create toolbar to 

set the properties before creating an object. 
■ Control–click an existing line or fill in the work area and select Properties from the 

context menu.
■ Control–click a line or fill in the FilmStrip and select Properties from the context 

menu.

Note: If accessed from the Options menu before creating the area, you cannot 
change the fill and/or line type.

Choose a fill type
Choose a line (or border) type
Change the fill properties

Change the line properties
Set the appliqué method

The selected properties are displayed
(the fill pattern, angle, and so on)
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Column Properties
Use the Column properties dialog to change the column type for a previously 
created column, and edit the properties as desired.

Note: You can change a previously created column to any other column type, or to 
a Satin Area.

To show the Column properties dialog
■ Control–click a column in the work area and select Properties from the context 

menu.
■ Control–click a column in the FilmStrip and select Properties from the context 

menu.

Object Properties
The following settings can be changed for stitch objects before or after they are 
created:

• Density
• Compensation
• Stitch Length
• Satin Line Width
• Fill and Satin Patterns
• Gap and Shape
• Start, End and Origin
• Motif
• Underlay
• Feathered Side

Choose a column type

Change the properties as desired

Click OK to apply your changes
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• Alignment Stitch Type

The settings for new areas and lines are set by clicking the Options pop-up menu  
in one of the Create toolbars, selecting the object type, and adjusting the settings 
in the properties dialog for that stitch type.

Note: Not all settings can be changed for all stitch types.

Note: Options that set properties for new objects are only applied when using the 
work area to create stitch objects. Objects created in the ExpressDesign Assistant 
do not use the current settings, but may be changed.

Density
Density of stitching may be set from 2 to 40, except for Satin line  which can be 
set from 2 to 15.

Pattern  and Spiral  fill areas may also have density gradients. The higher the 
number, the farther apart the stitches and the fewer stitches are produced. Pattern 
fills may also have multicolor gradient density. 

Note: Embroidery on thicker fabrics usually looks better with more stitch coverage, 
or a low density setting. Choose a low value such as 2 or 3 for heavy knit fabrics, a 
higher value such as 5 or 6 for a light material like linen or satin.

Compensation
All stitches have a tendency to pull in. The pull varies according to fabric weight 
and type. Compensation is used to make a whole design or areas within it 'bolder' 
by increasing their relative size. The higher the number, the bolder the areas 
appear. You can also alter compensation for any individual area of satin or fill.

Note: Compensation does not apply to feathered satin, satin line, or any fill other 
than pattern fill.
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You can set compensation from 0 to 30 for satin and 0 to 20 for fill areas. The 
setting for any Continuous satin , Satin area  and Pattern fill  area in the 
design is shown in the Area Properties for that satin or fill.

Note: Embroidery on thicker fabrics usually looks better with higher compensation, 
while on thin materials such as satin or twill a lower value or zero setting is usually 
more appropriate. As you create a design, use overlaps to prevent pulling from 
creating gaps between blocks of stitches that have different stitch directions. This 
provides 'built-in' compensation.

Stitch Length
Stitch Length can vary according to the object type as follows:

• Single Stitches : each stitch may be set from 1-12mm in 1mm steps, or 
embroidered without breaking up into smaller stitches.
Note: The current maximum stitch length for new Single stitches if it is desired to 
break them up into smaller stitches is shown in the General Preferences.

• Running stitch : may be set from 0.3-12mm in 0.1mm steps.
Note: Cutwork needle lines are automatically set to 0.3mm.

• Double stitch , Double Zigzag  or Triple stitch : stitches may be 
set from 1-12mm in 0.1mm steps.

• Motif line : stitches may be set from 1-20mm in 0.1mm steps.
• Motif fill : the length of the running or triple stitches making the motif shapes 

can be set from 1-12mm in 0.1mm steps.
• Feathered satin  (feathered both sides or one side): the maximum 

length of the stitches may be set from 2-30mm in 1mm steps.
• MultiWave fill , Shape fill  and Curved Crosshatch Fill : where 

Motifs are used, the length of the running or triple stitches making the motifs can 
be set from 1-12mm in 0.1mm steps.

• QuiltStipple , Contour  and Crosshatch  fill: the length of the 
running or triple stitches making the fill can be set from 1-12mm in 0.1mm steps.

• Echo Fill  and Curved Crosshatch Fill : the length of the running, 
double or triple stitches making the fill can be set from 1-12mm in 0.1mm steps.

Satin Compensation Pattern Fill Compensation
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Satin Line Width
Satin line or border width may be set from 1 to 12mm 
in 0.1mm steps.

Fill and Satin Patterns
Choose from over 250 system patterns for QuickStitch™ and 
Freehand fill areas. Choose any available motif for 
QuickStitch™ and Freehand motif fill areas, lines and tapered 
motif columns. Choose from 12 patterns for satin.

Note: Patterns in categories other than Standard are 
recommended for use in relatively large fill areas, as they 
have repeating patterns which work well when 'tiled' 
together. Pattern 36 produces a 'satin effect' fill stitch. The 
first four patterns in the Gradient & Lace category (253-
256) are recommended for multicolor gradient. The other 
eight (257-264) are suitable for a weave pattern combined 
with parallel crosshatch, as used for lace designs.

Set the angle of orientation for the stitches in Pattern fill, Motif fill and Crosshatch 
fill areas to any degree. 

Gap and Shape
The QuiltStipple , Contour , Crosshatch , Shape  
and Echo  styles of fill have additional properties that are 
unique to these fill styles. QuiltStipple fills can have curved 
or straight stipple stitching, and a gap setting controls the 
spacing of the lines of stipple stitch. Contour fill also uses a 
gap setting that controls the spacing of the lines of Contour 
stitch. Shape fills have a choice of 75 shapes, which control 
the path of the stitching. Crosshatch fills can use diamond, 
square and parallel styles. They have a gap setting that controls the spacing 
between the lines in the crosshatch. Echo Fills can use internal or external lines, 
varying the number or spacing. They also have a choice of three styles, with 
curved, square or diagonal corners.

Note: Richelieu bars may have a minimum gap or number of bars specified.

Start, End and Origin
Fill and satin areas have adjustable green start  and red end  points, which can 
be moved to any point defining the shape of the area. Use this to control the 
connection between an area and the objects that precede or follow it. For 
example, this is useful for shortening or hiding gaps so the need for trimming is 
reduced.
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Pattern, Shape, Radial and Spiral fill areas also have an orange origin . For 
Pattern Fill, the origin marker also has an adjustment handle .

• In a pattern fill area, the origin is the start point for the repeating pattern. 
• In Shape, Radial and Spiral fills, the origin is the point from which stitches radiate.

Moving the origin
You can move the origin anywhere on the work area.

■ For a pattern fill area, move the origin to change the position of the pattern, and 
rotate the handle to change the angle.

■ For Shape, Radial and Spiral fills, move the origin to change the radiation point of 
the fill. 

Motif
Choose any available motif for Motif fill areas  and 
lines . Motifs can also be used in Shape fills , 
MultiWave fills , Curved Crosshatch fills  and tapered 
columns . The size of motifs can be changed, and they 
can be stitched in either running or triple stitch. For motif 
fill areas, a second motif can be chosen for alternating lines, 
and the spacing, offset and angle of lines can be changed.

Note: You may also insert a single motif as running or triple 
stitch. See “Insert Single Motif” on page 52.

Underlay
Underlay is used to stabilize an area of fabric before stitching over it. Automatic 
underlay is optionally available for pattern fill areas, satin areas, satin column, 
Richelieu bars and satin line. To create underlay for other object types, use running 
stitch or single stitches.

Note: Embroidery designs created with the ExpressDesign Assistant have an option 
to create underlay for the whole design.

Feathered Side
Individual areas that were created as both sides feathered, Feather Side A or 
Feather Side B may have their feathered edges changed.

Feathered Both Sides Feathered Side A Feathered Side B
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Alignment Stitch Type
Alignment stitches are added (usually at the beginning) to an embroidery to align it, 
for example, with a previously embroidered design, or a background picture on 
fabric.

Alignment stitches are initially placed as a cross . Use the Alignment Stitches 
properties dialog to change the stitch type. Select from cross , top left , top 
right , bottom left , bottom right  and Point .

To open the Alignment Stitch dialog

Global Properties
The properties of all visible objects of a chosen type can be changed with Global 
Properties. 

Global Properties is not used for Stops, and has no effect on Color Changes.

Note: To change the properties of several objects of the same type, Command–
click or Shift–click the objects in the FilmStrip to select them, then Control–click 
and choose Properties.

Change Object Settings with Global Properties
1 Use the Control Panel to hide any objects you do not wish to affect. For example, hide 

objects by color, or use the Filters. 
2 Select an object of the desired type.
3 Control–click in the FilmStrip or on the work area and select Global Properties from the 

menu. 
The properties dialog for the object appears, with the current settings taken from the 
selected object. 

4 Adjust the properties as desired.
5 Click OK. 

All the settings in the dialog are applied to all visible objects of the same type.
When you click OK, the settings are applied globally even if you did not change 
anything. For example, if you have a fill area that already has the desired settings, 
select the fill area then select Global Properties and click OK to replicate the 
settings on all visible fill areas.

Note: Global Properties is only available if a single object is selected.

Manage My Fills
Use Manage My Fills to load new pictures for fill patterns to use with Pattern Fills, 
export an existing My Fill pattern as a picture and delete unwanted My Fills. 

Note: If you have a design using a My Fill pattern and give it to a friend, it is likely 
that their My Fill database will have different patterns to your My Fill database. 
Export the My Fill pattern and give the picture to your friend to import into their 
My Fill database. 
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To Select Manage My Fills
■ Choose Edit > Manage My Fills.

Export
Use Export to save a My Fill pattern as a picture. The picture can then be copied 
and imported into a friend’s My Fills.

■ Click Export. In the save dialog the file name is automatically set to the number 
used for the pattern in your My Fills.

Delete
Use Delete to remove the selected My Fill pattern. Delete can be used to remove 
unwanted patterns.

Import
Use Import to create a new My Fill based on a picture or a previously exported My 
Fill. After importing a picture, that fill will be available in the My Patterns  
category of the Pattern dialog. 

■ Click the Import button and in the open dialog select the picture to import, then 
click Open.

Note: The height and width of the picture must each be from 120 to 700 pixels.

Use a Bee for a My Fill Pattern
1 If required, choose File > New.
2 Choose Edit > Manage My Fills.
3 In the Manage My Fills dialog, click Import and the 

open picture dialog appears.
4 Browse to the folder Home/Premier+2/Samples/

Create/Pics.
Note: Simple black and white pictures are 
recommended. The height and width of the picture 
must be between 120 and 700 pixels.

5 Click 'Bee.bmp', then click Open. The bee fill is 
created and a preview sample is shown in the Manage 
My Fills dialog.

6 Click Close.
7 Click Precise Create  to open the Precise Create 

toolbar.
8 In the stitch types section choose Pattern Fill and No Border Line. 
9 Click the Create Precise Area or Line  button.
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10 Draw a large circle in the work area. It is filled 
with Pattern Fill.

11 Control–click the circle and choose Properties.
12 Click the Pattern button to open the Pattern 

dialog.
13 Click My Patterns . The My Patterns 1 

category is displayed.
Alternatively, you can choose this category from 
the pop-up menu.

14 Click the bee fill pattern that you just created.
Note that the bee design has automatically been 
given pattern number 501. Enter this number to 
go directly to the bee pattern.

15 Click OK to close the Pattern dialog.
The bee pattern is now displayed in the Area 
Properties dialog.

16 Click OK to close the Area Properties dialog 
and view the bee fill pattern on your fill.
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6Motifs and Machine Stitches

Use motifs to personalize your motif fills and lines. Create your own 
motifs to add to My Motifs, or create your own .spx machine 
stitches.

Using Motifs
A motif is a small element designed so that it will repeat along a line or along 
multiple lines to fill an area. Choose any available motif for motif lines, tapered 
motif columns and fill areas. You may also insert a single motif.

All the system motifs are in the Universal Group. My Motifs is used for motifs that 
you create. You can create motifs to add to My Motifs, and machine stitches for 
certain machines.

Motif Selection
Use the Motif selection dialog to select motifs for motif lines, fills, tapered motif 
columns, and as lines within a Shape, MultiWave or Curved Crosshatch Fill.

The delete function is only available for motifs you have created in My Motifs.

Note: You can only delete motifs in My Motifs if two or more motifs have been 
created.

Choose a motif Group and Category

Select a motif

Flip the motif horizontally or vertically

Set the height and width of the motif

Adjust the dimensions proportionally (lock closed)
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Insert Single Motif
Use Insert Single Motif to insert a single motif into the current design, using the 
motif selection dialog.

The motif is automatically selected so that it can be moved, resized, mirrored, 
rotated, copied or cut.

Note: You may also modify the inserted motif and save the selection as a new My 
Motif.

■ Choose Edit > Insert > Insert Single Motif.

Create and Manage Motifs
Use Create Motif from Selection to make a motif from a Running Stitch design. Use 
the My Motifs page of the Motif Selection dialog to delete unwanted My Motifs.

Use Create Motif from Selection to save the running stitch design or selected 
block of running stitch on the screen to the My Motifs database. There is no 
confirmation of this action.

■ Choose Object > Create Motif from Selection.

Create a Motif
1 Select the Precise Create  toolbar.
2 In the Precise Create toolbar, choose Running Stitch  in the 

Line pop-up menu.
3 Deselect the Fill and Appliqué buttons so they are gray, not 

blue. 
4 Select Create Precise Area or Line .
5 Place points, using the Command key to create corner or 

square points, to draw the outline of a tree from left to right. 
Double-click or press Return to finish the line.
Start and finish on the same horizontal line.
Note: The start and end stitches should always be aligned horizontally, with the start stitch 
on the left and the end stitch on the right.

6 Choose File > Save and save the motif design as Tree Outline.edo.
7 Ensure that the tree outline is selected.
8 Choose Object > Create Motif from Selection.
9 If the first and last stitches are not aligned horizontally, a message appears to give you the 

option to rotate the motif or add an alignment stitch.Click the desired option and then 
export the motif to the My Motifs database.
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Managing My Motifs
Use the My Motifs page of the Motif Selection dialog to delete unwanted My 
Motifs.

To back up My Motifs, use the Backup My Settings feature in PREMIER+™ 2 
Configure.

Export as Machine Stitch
Use Export as Machine Stitch to save the 
running stitch design or selected block of 
running stitch as a .spx machine stitch for 
certain sewing machines. Save and name 
the design file. PREMIER+™ 2 Create 
displays the Save Machine Stitch dialog.

■ Choose Object > Export as Machine Stitch. 

Note: If the first and last stitches are not aligned, a message appears to give you the 
option to add an alignment stitch.

To send the stitch to your connected machine, choose Object > Send Machine 
Stitch. Alternatively, copy the Spx stitch file to a USB Embroidery Stick.

Send Machine Stitch
Use Send Machine Stitch to send a saved Spx stitch file to your connected machine.

■ Choose Object > Send Machine Stitch.

Insert Machine Stitch
Use Insert Machine Stitch to open an existing stitch to modify it, or to export it as 
a motif. PREMIER+™ 2 Create displays the Open dialog so you can choose a 
machine stitch design file to open. Spx files may be loaded.

■ Choose Edit > Insert > Insert Machine Stitch.

Choose the My Motifs Group and Category

Select a motif to delete

Click to delete the motif
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7Editing a Design

After you have created an object such as a line, fill or hole, you may 
want to change its properties; for example the motif size, fill pattern 
or stitch length. 

Select individual objects, or select objects as a block. See “Select a Block of 
Objects” on page 65.

To Edit an Object
■ Control–click the object in the FilmStrip, and choose Properties. 
■ Control–click the object in the work area and choose Properties.
■ To change the properties of all visible objects of the selected type, Control–click in 

the FilmStrip or in the work area and choose Global Properties.
■ To change the properties of several objects of the same type, Command–click or 

Shift–click the objects in the FilmStrip to select them, then Control–click and 
choose Properties.

You can then make the desired changes in the properties dialog. See “Area 
Properties” on page 42.

Note: If an object is difficult to select, use the color worksheet, object Filters and 
Draw Range to help isolate it, then select it on the FilmStrip.

Select Objects
In PREMIER+™ 2 Create, designs are made up of a sequence of lines and areas 
(e.g. stitch lines, fills and columns). Each area, line or column is defined by a 
number of points that can be seen in the work area. The selected object is 
highlighted in the FilmStrip.

Select a Place to Insert New Objects
1 In the FilmStrip or in the work area, find the object after which you wish to insert new 

objects and click it to highlight it. 
2 Select one of the Create tools. The create cursor  can be seen at the insert point.
3 Insert the new object. It appears below the object that you selected.

Insertion Markers
When a Freehand tool is selected, a marker shows the location of the last point of 
the preceding object. This is where new objects are inserted:

■ When objects will be added to the end of the design, the marker is pink .
■ When objects are to be inserted (i.e. the selected object is not the last object in 

the design), the marker showing the final point of the selected object is orange .
■ When objects are to be inserted, a blue marker  shows the position of the first 

point in the next object in the design.
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Select an Object to Edit
■ In the work area, click an object to show the points that make it up, and check 

what type it is in the FilmStrip. 
■ Click an object in the FilmStrip. It is highlighted in the work area.

You can then drag the points on the object to change its shape, delete it, or 
Control–click and choose Properties to change the stitch type.

Step Through Designs
■ Click an object in the work area and press the arrow keys on the keyboard to step 

through all the objects in sequence. (If a selection box is visible, then use the arrow 
keys to nudge the selected object(s).)

■ Click an object in the FilmStrip and use the up and down arrow keys on the 
keyboard to step through all the objects in sequence. 

■ Click the Page Up (or fn ↑), Page Down (or fn ↓), Home (or fn ←) and End (or 
fn →) keys to move rapidly up and down the FilmStrip.

■ Click Select Last Visible Object  to move to the last object in the FilmStrip.
■ Control–click the FilmStrip and choose Display Only From Start to show only the 

objects from the start to the selected object. 
■ Control–click the FilmStrip and choose Display Only To End to show only the 

objects from the selected object to the end of the design.
■ Control–click the FilmStrip and choose Display Only Selected to show only the 

selected object. 
Note: The color worksheet, object filters and Draw Range are useful to isolate 
objects.

Select Several Objects
■ Click the top of a sequence of objects selected in the FilmStrip, then hold the Shift 

key and click the bottom of the desired sequence (Shift-click).
■ Hold the Command key and click the desired objects (Command-click). 

Delete Object
Use Delete Object to remove the currently selected object from the design. Select 
the object in the work area or in the FilmStrip.

To delete the selected object
■ Click Actions  on the toolbar and choose Delete Object.
■ Control–click the selected object and choose Delete Object.
■ Control–click the object in the Filmstrip and choose Delete Object.
■ Choose Edit > Delete Object.
■ On full-size keyboards, press Delete ⌦. 
■ On Mac portable keyboards, press Function–Delete or Function–Backspace 

(fn ⌫ ).
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Insert Commands
Use the FilmStrip to insert a new Color Change or Stop Command immediately 
after the selected object.

Insert a Command
■ Select the object above the insertion point, then Control–click that object and 

choose the desired option from the context menu.

Insert Color Command
Insert a Color Change  after the currently selected object. The Color Selection 
dialog appears so you can choose the new color. 

Insert Stop Command
Insert a Stop  after the currently selected object. 

Note: A Stop will not be inserted if this would place two Stops together.

Change Objects’ Sequence
Objects and groups of objects can be dragged to 
move them up and down the FilmStrip, or moved 
with the arrow (Layout Order) buttons. This changes the order of the objects, and 
also changes the order in which the stitches are created for the final embroidery. 
See “FilmStrip” on page 24.

View the object color in
the Thread Color Bar

The first object is always a color

Objects are shown by their
shape or a marker

View the name of the object type

Scroll up and down the FilmStrip

Use the Layout Order buttons
to move objects in the FilmStrip

Select the last visible object

No line between linked objects

Line between chains 
of linked objects

Display objects within groups
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Moving an object up and down the FilmStrip does not change the position of the 
object on the work area. However, it may change the appearance of the design 
according to whether or not it changes the overlap with adjacent objects. For 
example, the color may change.

Note: You cannot move or delete the first visible object in the FilmStrip. Also, you 
cannot move objects above the first visible object in the FilmStrip. This ensures 
that, when it is visible, the initial color change in the design cannot be moved or 
deleted and nothing can be moved before it, unless it is another color change.

Drag an Object within the FilmStrip
1 To move an object by dragging it, click the desired object and drag it up or down the 

FilmStrip. A bar moves up and down the list to show the new list position. 
2 Release the mouse button to drop the object at the desired point.

Drag Several Objects in the FilmStrip
1 Select a number of objects in the FilmStrip.
2 Drag one of the objects in the selection. A bar will show where the objects can be inserted 

in the FilmStrip. 
3 Move the bar up or down the FilmStrip to the desired insertion point. 
4 Release the mouse button to insert the objects.

Note: Hidden objects will not be moved.
5 To move to a part of the FilmStrip that is not visible, move the pointer above the top or 

below the bottom of the list. The list scrolls automatically. 
6 To scroll faster, move the pointer further above or below the list. 
7 Move the pointer back into the list to stop scrolling.

Note: Moving the pointer onto the scroll bar has no effect when dragging an object up or 
down the FilmStrip.

Move an Object With the Layout Order Buttons
1 To move an object with the Layout Order buttons, click the desired object. It is highlighted 

in the FilmStrip.
2 Click Move Backwards  to move the object one step up the FilmStrip (towards the first 

stitch object in the design). A bar moves up the list to show the new position.

Note: Move Forwards  will move the object one step down the FilmStrip. Move to 
Back  will make the object the first to be stitched out, and Move to Front  the last.

3 Move the object to the desired position.
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Edit Lines and Areas
The shape of a line or area can be changed in the work area by moving the points 
that define its outline. The points for the currently selected object are shown.

To Select an Object
■ Click on the object in the work area or the FilmStrip. 
■ Use the arrow keys to step through the objects in the order they are used in the 

design.

Points, Angle Lines and Markers
When the desired line or area is selected, its points can be 
moved. The points are shown as small circles or squares. 
Square points are used for straight sections and corners. 
Round points are used for curves.

Some stitch object types, such as single stitches have a 
fixed number of points.

Other objects, such as fill areas, running stitch and satin 
lines, can have any number of points, and points may be 
inserted and deleted, allowing greater control over their 
shapes. The start and end points for fill and satin areas can be changed, typically to 

A Single Stitch is defined
by two square points 
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reduce the need for trimming. Satin areas have angle lines that are used to control 
the satin angle.

Color change and stop commands, and alignment stitches are shown as a single 
point when selected.

Points
The points that define the currently selected stitch object 
(satin column, fill area, running stitch, etc.) are shown as 
small squares and circles. Emboss lines and MultiWave lines 
have similar points.

The points used to start and end all fill and satin areas are 
shown by the start  and end  markers. Some types of 
fill areas also have an origin, marked by an orange circle . 
In addition, satin areas have stitch angle lines with pink 
hexagonal ends.

Edit Points
Use Edit Points  to enable the moving and editing of an object’s points if another 
function is being used. Alternatively, click an object to select it and you will be in 
Edit Points mode.

Select Edit Points

■ In the Control Panel, click Edit Points . 
■ Choose Edit > Points > Edit Points.
■ Press ⇧⌘E

Select and Move Points
1 In the Control Panel, click Edit Points . 
2 Click an object in the FilmStrip, or on the work area, to select it and view its points. 

Fill areas have as many points as needed to 
define their outlines, and also have 
moveable start, end and origin markers

Satin areas have moveable start and end 
markers, and adjustable stitch angle lines

Start
Marker

Origin
Marker

End
Marker

Start
Marker

End Marker

Stitch Angle
Lines
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3 Drag the points to change the shape of the object.
Note: Moving the points that define a satin area may affect the stitch angle lines, but moving 
the stitch angle lines will not affect the shape of a satin area.

Straight and Curved Lines
Lines using round points are curved, and lines using square points are straight. The 
outlines defining most types of lines and areas can have both curved and straight 
sections:

• To have any curves, a line must be defined by at least four points.
• To have any curves, an area must be defined by at least three points.
• The first and last pair of points for a column are always square.

Change a Round Point to a Square Point
■ Hold down the Shift key and click the point without moving it.

When adjacent points are square, the line between them is straight. This is useful 
if, for instance, a point was not added as a corner at the desired place on a fill area 
or stitch line.

Change a Square Point to a Round Point
■ Click the point without moving it. 

There must be at least two round points next to each other to make a line curved, 
so if there is one round point between two square points then the lines to the 
round point are straight.

Note: If a line does not have enough points to make the desired section curved, 
insert an extra point to use for the curve.

Insert Points
Use the Insert Points pointer  to insert a point in the currently selected object 
outline, or a stitch angle line for a satin area.

Points can be inserted into all line and area types, including emboss lines and 
MultiWave lines. The only exception is Single Stitch, where points cannot be added 
or removed.

Point is a curve Point is a corner after Shift–click
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Select Insert Points

■ In the Control Panel, click Insert Point , then click to insert points.
■ Choose Edit > Points > Insert Points, then click to insert points.
■ Use Command–click to add a point at the selected position.
■ Press ⌥⌘E

Note: A pair of points is inserted when a point is added to a column.

Stitch angle lines can be added to satin areas in the same way.

Delete Points
Use the delete points pointer  to remove points from the currently selected 
object outline, or a stitch angle line for a satin area.

Points may be deleted from all line and area types, including emboss and MultiWave 
lines, except Single Stitch.

You may not delete all the points for an object. 

• A fill or satin area must have at least three points. 
• Satin border, motif lines and running, double and triple stitch lines must have at 

least two points. 
• A column must have a least four points (the start and end pairs).
• A satin area must also have at least one angle line. 

■ In the Control Panel, click Delete Point , then click to delete points.
■ Choose Edit > Points > Delete Points, then click to delete points.
■ Use Option–click (⌥) to delete a point at the selected position.
■ Press ^⌘E

To remove all the points for an object, use Delete Object.

Convert Points and Bezier Lines
Use the Convert Points  functions to change between types of points in a line in 
Bezier Mode, or to change a Point Line to a Bezier Line, or a Bezier Line to a Point 
Line.

Note: For information on how to draw and adjust Bezier Lines, see the 
PREMIER+™ 2 Create Reference Guide.

Use Convert Points to Corner  to change the selected point in a Bezier line to a 
Corner point (a point with no handles).

■ In the Control Panel, click Convert Points , then choose Convert Points to 
Corner . 

■ Choose Edit > Convert Points > Convert Points to Corner.

Use Convert Points to Smooth  to change the selected point in a Bezier line to 
a Smooth point (a point with handles that can be adjusted independently).
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■ In the Control Panel, click Convert Points , then choose Convert Points to 
Smooth . 

■ Choose Edit > Convert Points > Convert Points to Smooth.

Use Convert Points to Symmetric  to change the selected point in a Bezier line 
to a Symmetric point (a point with handles that are the same distance from the 
point).

■ In the Control Panel, click Convert Points , then choose Convert Points to 
Symmetric . 

■ Choose Edit > Convert Points > Convert Points to Symmetric.

Start and End Points for Areas
The start and end points for fill and satin areas are shown by circular markers. The 
start marker  is on the inside of the object, and the end marker  is on the 
outside of the object.

Move the Start and End Points for Areas
■ Drag the desired marker. Move the marker to the point that you wish to use as the 

new start or end point of the area. Drop at the desired point and the position of 
the marker will change.

Note: The marker snaps to the nearest point on the edge of the object. If an area 
does not have a point in the desired position, insert a point at that place.

The Origin for Areas
Some types of fill areas have an origin, marked by an orange circle . This is used 
to move the start point for the pattern in a pattern fill, or the center point for 
Radial fill, Spiral fill and Shape fill types.

Note: Use the Origin to control how the pattern is repeated in a pattern fill area.

For Radial fill, Spiral fill and Shape fill areas, the origin can also be moved. This sets 
the center point for the fill, such as the point from which stitches radiate on a 
Radial fill.

Move the Origin for Areas
■ Drag the origin marker  to the desired position. The origin can be moved 

anywhere on the design area.

You can create several of the same types of fill area with a common origin. Move 
the origin to the same grid position for all the desired areas, so that the pattern of 
stitches is unified across the group of areas.
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Change the Stitch Angle for Satin Areas
Satin areas have stitch angle lines that show and adjust the 
angle of the stitches across the area. The stitch angle lines 
have hexagonal handles at each end that are used to adjust 
each line individually.

Drag the desired hexagonal handle. Drop at the desired point 
and the position of the angle line will change. If the line does 
not move, this is because the new end point is not usable. 
This will happen if, for example, you attempt to force two 
angle lines to cross each other within the area.

Add Angle Lines
■ To add angle lines, click Insert Point  (or press the Command key), then draw a 

line where you want to add the line.

Delete Angle Lines
■ To delete angle lines, click Delete Point  (or press the Option key), then click 

the hexagon at either end of the line to be deleted.

Note: A satin area must have at least one angle line. Therefore, the last angle line 
may not be deleted.

Delete Hole
Use Delete Hole  to delete one or more holes from the currently selected area. 

Remove a Hole from an Area
1 Click the Control Panel button  on the main toolbar to select the Control Panel.
2 Click a fill area containing one or more holes. The points that make up the hole are shown.
3 In the Delete pop-up menu in the Control Panel, select Delete Hole  to enable hole 

removal.
4 Move the pointer over the edge of a hole. The pointer changes to the delete pointer .
5 Click the edge of the hole. The hole is removed from the design.
6 If desired, delete further holes.
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Delete Emboss Line
Use Delete Emboss Line  to delete one or more embossed lines from the 
currently selected area. 

Note: Use Delete a Point to remove individual points from an emboss line. See 
“Delete Points” on page 61.

Remove an Emboss Line from an Area
1 Click the Control Panel button  on the toolbar.
2 Click a fill area or column containing one or more emboss lines. The points that make the 

object and its emboss lines are shown.
3 In the Delete pop-up menu in the Control Panel, select Delete Emboss Line  to enable 

emboss line removal.
4 Move the pointer over an emboss line. The pointer changes to the delete pointer .
5 Click the emboss line. It is removed from the fill area.
6 If desired, delete further emboss lines.
7 Control–click to deselect the function.

Delete MultiWave Line
Use Delete MultiWave Line  to delete one or more MultiWave lines from the 
currently selected MultiWave Fill area.

Note: Use Delete a Point to remove individual points from an MultiWave line. See 
“Delete Points” on page 61.

Remove a MultiWave Line from a MultiWave Fill Area
1 Click the Control Panel button  on the toolbar.
2 Click a MultiWave fill area containing one or more MultiWave lines. The points that make 

the object and its MultiWave lines are shown.
3 In the Delete pop-up menu in the Control Panel, select Delete MultiWave Line  to enable 

MultiWave line removal.
4 Move the pointer over a MultiWave line. The pointer changes to the delete pointer .
5 Click the MultiWave line. It is removed from the MultiWave fill area.
6 If desired, delete further MultiWave lines.
7 Control–click to deselect the function.

Break Apart
Use Break Apart to break apart a fill area with a border into a separate line and fill 
area.

■ Choose Object > Break Apart.

Reversal Functions
Reverse Column End to End
Reverse the order of all the points defining a column so that the start becomes the 
end, and vice versa.
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Note: This option is only available when a column is selected.

■ Choose Object > Reversal > Reverse Column End to End.

Reverse Column Side to Side
Swap each pair of points within a column. 

Thus, if a column started with a left point and ended with a right point, then all 
right points would be swapped to become left points. The column would then start 
on the right and end on the left.

Note: This option is only available when a column is selected.

■ Choose Object > Reversal > Reverse Column Side to Side.

Reverse Line
Reverse the order of the points defining a line so that the start becomes the end, 
and vice versa.

Note: This option is only available when a line is selected.

■ Choose Object > Reversal > Reverse Line.

Select a Block of Objects
The select functions in the main toolbar allow you to select a block of objects. A 
selected block of objects can be resized, rotated, mirrored, moved, copied and cut.

■ Click on an object in the FilmStrip or work area to select it. Command–click or 
Shift–click in the FilmStrip to select additional objects individually or in a sequence. 
Use the Select Mode tools to replace, add to, or remove from your selection. Note: 
Use Control–click to finish using a select tool, or select a different create or select 
tool.

When a block has been selected, it has a selection box around it on the work area. 
The selection box has handles which are used to resize, rotate and flip the block.

Note: The handles are blue to indicate that you can freely manipulate the selection 
without changing density or stitch length in the objects. This is because the stitches 
are only generated when you use Export Embroidery.

Flip Vertical Handle

Rotate
Handle

Resize
Handle

Flip
Horizontal

Handle



66          PREMIER+™ 2 Create   Editing a Design 

Move and Resize a Block of Objects
■ Drag inside the block to move it. 
■ Drag the square corner handles  to resize the block. 

Note: Hold down the Shift key as you drag to resize proportionally. Hold down the 
Option key to resize from the center.

■ Drag the round rotate handle  to rotate the block freely. 
■ Click the triangular handles to flip the block horizontally  or vertically .

Note: When making a selection, only objects that are completely enclosed by the 
selection line (box, freehand line) are included in the selection. If you cut across a 
Running stitch line when making a selection, it is not included because it was not 
completely enclosed in the selection.

Inserting or Pasting a Block
When a new selection is added to a design by paste or one of the insert functions, 
it is automatically selected as the current block.

Deselect a Block
■ Click the work area outside a block to deselect it. The selection box around the 

block will disappear.

Box Select
With Box Select , drag to draw a rectangle around the area you want to select. 
Only objects that are completely enclosed by the selection line are selected.

■ In the main toolbar, click Box Select . 
■ Choose Edit > Box Select.

Freehand Point Select
With Freehand Point Select , place points to select a block of stitches of any 
shape around the desired area. Only objects that are completely enclosed by the 
selection line are selected. Freehand Point Select may be easier to use than 
Freehand Select for precise selections.

■ In the main toolbar, click Freehand Point Select . 
■ Choose Edit > Freehand Point Select.

Freehand Select
With Freehand Select , drag to draw an irregular outline around the desired 
area. Only objects that are completely enclosed by the selection line are selected.

■ In the main toolbar, click Freehand Select . 
■ Choose Edit > Freehand Select.
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Replace, Add and Remove Selections
Use Replace Selection  to replace the currently selected objects with the new 
selection. Use Add to Selection  to add the new selection to the currently 
selected objects. Use Remove from Selection  to remove the new selection 
from the currently selected objects.

Select All Visible
Select All Visible  selects all visible objects in the design.

■ In the main toolbar, click Select All Visible . 
■ Choose Edit > Select All Visible.
■ Press ⌘A

Deselect All
Deselect All  will deselect every selected object, including any that are outside 
the chosen hoop.

■ In the main toolbar, click Deselect All . 
■ Choose Edit > Deselect All.
■ Press ⇧⌘A

Multiple Select and Groups
Multiple Select
Use multiple select to select more than one object at a time. The selected objects 
are surrounded by a selection box with a solid outline, and blue handles. The 
whole selection can be scaled, rotated and mirrored. 

Note: If you click outside the selection box, the objects become separate. Use 
Undo, or select them again to recreate the multiple selection.

Select Several Objects
■ In the FilmStrip, hold down the Command key and click the desired objects.
■ Use one of the multiple select tools in the Select area.

A selection box is placed around the selected objects.

In PREMIER+™ 2 Create, you can edit objects individually, in a selected block, or 
in groups which remain as a selection after saving. To reshape or change the 
properties of an individual object inside a group, select it on the FilmStrip.

Note: When a design including groups is loaded using Insert or Open, all sections 
are grouped together, ready for moving, resizing and so on.
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Group
Use Group  to make a more permanent group of all the currently selected 
objects. Use Group to group the objects permanently, or to make a temporary 
Group while moving or editing them.

Note: A group can be modified in the same 
way as a selection. You can move, resize, 
mirror and rotate it.

The grouped objects are surrounded by a 
selection box with a solid outline, and 
orange handles. The group can be scaled, 
rotated and mirrored.

Note: If you click outside the selection box, 
and then click one of the objects within the 
group, the objects will still be grouped.

Create a Group of Objects
■ Select several objects in the FilmStrip or on the work area, then click Group .
■ Select several objects, then choose Object > Group.
■ Press ⌘G

Use Ungroup  to split the selected group into the objects which make it up.

Note: Ungroup can only be used when a group is selected.

Ungroup a Group of Objects
■ Select a Group, then click Ungroup .
■ Select a Group, then choose Object > Ungroup.
■ Press ⌥⌘G

Select Similar from Visible
Use Select Similar from Visible to select all visible objects with similar properties 
(i.e. the same name in the FilmStrip); for example, select all Radial Fill areas, or all 
Satin Lines.

Note: Select Similar from Visible selects all Pattern Fills, whether or not they have a 
border, but does not select Pattern Fill Appliqué areas at the same time as Pattern 
Fill.

Select Similar from Group
Use Select Similar from Group to select all objects with similar properties (i.e. the 
same name in the FilmStrip) that are in the same Group.

Note: Objects with similar properties that are in a different Group, or in no Group 
will not be selected.
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Scale to Fit Hoop
Use Scale to Fit Hoop to resize the design in the work area proportionally, to fit 
within the boundaries of the hoop, centered in the hoop. The whole design is 
resized, including hidden areas.

Note: Use this to resize a whole design to fit in a different hoop. You should 
consider whether to change settings or stitch types. For example, when enlarging 
you could add a pattern to wide satin columns.

Rotate 45
Rotate 45 rotates the selected block of objects in 45 degree steps.

To rotate a block of objects freely in the work area, drag the round rotation handle 
on the right side of the block.

To Rotate a Block of Objects by 45 Degrees
■ Select the block of objects, then choose Object > Rotate 45.

Undo to return to the previous angle.

Modify Block
Use Modify Block to open a dialog where you can resize and rotate the selected 
block.

To Open the Modify Block Dialog
■ Select the block, then choose Object > Modify Block.

In the Modify Block dialog you can change the height and width of the block, or 
rotate the block. The changes are made when you click OK.

Click the lock button to adjust dimensions proportionally (lock closed ) or non-
proportionally (lock open ).

Size
Adjust height and width separately, or select Lock to change them proportionally. 
The size is given in millimeters, and as a percentage of the size when the dialog was 
opened.

Changing the Size
■ Enter a number in the height or width number box.
■ Use the arrows to increase or decrease the height or width.
■ Select Lock to automatically resize height together with width.

Rotate
Rotate the block to the desired angle.

Rotating the Block
■ Enter a number in the rotation angle number box.



70          PREMIER+™ 2 Create   Editing a Design 

■ Use the arrows to increase or decrease the angle of rotation.
■ Drag the rotational slider to rotate the block.

Cut, Copy and Paste Objects
Once objects have been selected with Box Select, Freehand Point Select, Freehand 
Select or Select All Visible, they can be cut and copied. The selection of objects on 
the clipboard can be pasted as many times as desired in the work area of the 
PREMIER+™ 2 Create app.
Note: Only objects that are completely enclosed by the selection line are selected. 

Cut
Use Cut to cut out the selected objects and place them on the clipboard. The 
selection can then be pasted back in.

■ Click Actions  on the toolbar and choose Cut.
■ Control–click and choose Cut.
■ Choose Edit > Cut.
■ Press ⌘X

Copy
Use Copy to copy the selected objects to the clipboard, without affecting the 
objects on the work area. The selection can then be pasted back in.

■ Click Actions  on the toolbar and choose Copy.
■ Control–click and choose Copy.
■ Choose Edit > Copy.
■ Press ⌘C

Paste
Use Paste to paste the objects on the clipboard back into the design.

Note: Color changes are only transferred if they are within the copied block. If 
there are no Color changes in a pasted block then all the objects will use the 
thread color already in use where the block is pasted.

■ Click Actions  on the toolbar and choose Paste.
■ Control–click and choose Paste.
■ Choose Edit > Paste.
■ Press ⌘V

Paste into New Window
Use Paste into New Window to paste the objects on the clipboard back into a 
design on a different window.

Note: Color changes are only transferred if they are within the copied block. 
Therefore some or all objects may be the initial blue color.
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■ Choose Edit > Paste into New Window.
■ Press ⇧⌘V

Paste into Center
Use Paste into Center to paste the objects on the clipboard into the center of the 
work area.

Note: Color changes are only transferred if they are within the copied block. If 
there are no Color changes in a pasted block then all the objects will use the 
thread color already in use where the block is pasted.

■ Choose Edit > Paste into Center.
■ Press ⌥⌘V

Paste and Replace
Use Paste and Replace to paste the objects on the clipboard, replacing the objects 
that are currently selected on the work area at their position in the FilmStrip.

Note: Color changes are only transferred if they are within the copied block. 
Therefore some or all objects may be the initial blue color.

Paste and Replace can be used to copy part of a design to a separate window, 
adjust it, and use it to replace the section that was originally copied.

■ Choose Edit > Paste and Replace.
■ Press ^⌘V

Duplicate Selected
Use Duplicate Selected to make a copy of the selected object or block. The copy is 
automatically pasted on the work area below and to the right of the original.

■ Select the object or block, then click Actions  on the toolbar and choose 
Duplicate Selected.

■ Choose Edit > Duplicate Selected.
■ Press ⌘D
■ Control–click and choose Duplicate Selected.

Copy Embroidery
Use Copy Embroidery to copy the whole design to the clipboard, without affecting 
the objects on the work area. The design can then be pasted into any PREMIER+™ 
2 Embroidery System app.

■ Choose Edit > Copy Embroidery.
■ Press ⌘E

Insert Design
Use Insert Design to insert existing outline designs (.edo files) into the current 
design. The design is automatically selected so that it can be moved, resized, 
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mirrored, rotated, copied or cut. Designs are inserted at the size they were 
created.

■ Click Actions  on the toolbar and choose Insert Design.
■ Choose Edit > Insert > Insert Design.
■ Press ⌘I

Insert Embroidery
Use Insert Embroidery to insert any embroidery into the current design, or into a 
new window. 

An inserted embroidery is automatically converted to stitch objects and selected 
as a block. The first object in the block is placed after the selected object or the 
last visible object in the design. The block can be moved, resized, mirrored, 
rotated, copied or cut. Embroideries are inserted at the size they were created.

■ Choose Edit > Insert > Insert Embroidery.

Insert Lettering
Use Insert Lettering to insert letters from any PREMIER+™ 2 Embroidery System 
font into the current design. The character is automatically selected so that it can 
be moved, resized, mirrored, rotated, copied or cut. Characters are inserted at a 
fixed size relative to the 'A' character in the font.

■ Click Actions  on the toolbar and choose Insert Lettering.
■ Choose Edit > Insert > Insert Lettering.

Insert Lettering into a Design
1 Click Actions  on the toolbar and choose Insert Lettering.
2 In the Insert Lettering dialog, click the displayed font. The Font Viewer opens.

Choose a font

Set the font size
Choose a letter
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3 Scroll through the Font Viewer to select a font.
Alternatively, search for a font by name.

4 Set the Size in millimeters as desired, from 3mm to 
200mm.
This sets the height of the 'A' character in the font. 
Other characters and symbols are sized accordingly.

5 Choose a letter from the pop-up menu and click 
Insert. The letter is placed in the work area.

6 Select and Insert other letters to create a word.
7 Click Close to finish placing lettering.

The last placed letter is automatically selected with 
Box Select , so you can adjust it as desired.

8 Repeat to place additional text as desired.

Insert SuperDesign
Use Insert SuperDesign to insert a SuperDesign from the SuperDesign sets 
available in PREMIER+™ 2 Create. SuperDesigns are special designs that can be 
resized with constant stitch density. Some SuperDesigns are multicolored, and the 
stitch type and style for many can be changed. Alter the size, proportions, stitch 
type and thread color. 

■ Click Actions  on the toolbar and choose Insert SuperDesign.
■ Choose Edit > Insert > Insert SuperDesign.

Notes and Settings
Use the Notes  and Settings  to add a description to your design. The Notes 
and Settings boxes are found on the Control Panel.

To Edit the Notes or Settings
■ In the Control Panel , select Notes  or Settings , then click Edit  to open 

the Notes or Settings dialog and add some text.

Note: Use Option–Return or Control–Return to start a new line of text.

Undo and Redo
Undo
Use Undo to reverse the last action. Unlimited Undos are possible. Every time you 
use Undo, the previous action is reversed. If you are not satisfied with the result of 
the Undo, you can use Redo.

Note: The Zoom commands cannot be reversed using Undo.

To use Undo
■ Click Actions  on the toolbar and choose Undo.
■ Choose Edit > Undo.
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■ Press ⌘Z
■ Control–click and choose Undo.

Note: When using Undo from the Edit menu, the name of the specific action to be 
undone is listed.

Redo
Use Redo to reverse the last action that was undone by Undo. If you are not 
satisfied with the result of the Redo, use Undo. 

To use Redo
■ Click Actions  on the toolbar and choose Redo.
■ Choose Edit > Redo.
■ Press ⇧⌘Z
■ Control–click and choose Redo.

Note: When using Redo from the Edit menu, the name of the specific action to be 
redone is listed.
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